Автоматическое копирование конфига на FTP

Тема в разделе "Скрипты", создана пользователем Roman Markov, 12 янв 2020.

  1. Roman Markov

    Roman Markov Участник

    Скрипт для копирования конфигов на FTP отрабатывает, но файлы на FTP-сервере оказываются нулевой длины. FTP-сервер сообщает, что ему ноль байт и передавали. При этом на Микротике сохраненный файл нормальный.

    Увеличение Delay до 30 секунд не помогло.

    Пробовал разные FTP-сервера, проблема не в сервере.

    :local myname "RouterName"
    :local fname ($myname.");
    :local bname ($myname".backup");
    :local ename ($myname".rsc");
    :local ftpaddr "10.1.1.1";
    :local ftpuser "Mikrotik";
    :local ftppass "MyPassword@";


    /system backup save name=$myname password=MyPassword@;
    :delay 10;
    /export file=$myname
    :delay 10;

    /tool fetch address=$ftpaddr src-path=$myname user=$ftpuser password=$ftppass port=21 upload=yes mode=ftp dst-path=$bname
    :delay 15;
    /tool fetch address=$ftpaddr src-path=$myname user=$ftpuser password=$ftppass port=21 upload=yes mode=ftp dst-path=$ename
    :delay 15;
     
    Последнее редактирование: 12 янв 2020
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Если все сделать руками - работает?
     
  3. Roman Markov

    Roman Markov Участник

    Да, если вручную команды выполнить в командной строке - все заливает как надо

    ---------------------

    Лог FTP-сервера при заливке файла нулевой длины из скрипта:

    [5] Mon 10Feb20 19:15:12 - (001507) Connected to *********** (Local address 192.168.0.11)
    [6] Mon 10Feb20 19:15:12 - (001507) 220 FTP Server ready...
    [2] Mon 10Feb20 19:15:12 - (001507) USER Mikrotik
    [6] Mon 10Feb20 19:15:12 - (001507) 331 User name okay, need password.
    [2] Mon 10Feb20 19:15:12 - (001507) PASS xxxxx
    [5] Mon 10Feb20 19:15:12 - (001507) User MIKROTIK logged in
    [6] Mon 10Feb20 19:15:12 - (001507) 230 User logged in, proceed.
    [2] Mon 10Feb20 19:15:12 - (001507) TYPE I
    [6] Mon 10Feb20 19:15:12 - (001507) 200 Type set to I.
    [2] Mon 10Feb20 19:15:12 - (001507) PASV
    [6] Mon 10Feb20 19:15:12 - (001507) 227 Entering Passive Mode (*,*,*,*,160,55)
    [2] Mon 10Feb20 19:15:12 - (001507) STOR Router.rsc
    [4] Mon 10Feb20 19:15:12 - (001507) Receiving file e:\backup\server\clients-internet-backup\mikrotik\Router.rsc
    [6] Mon 10Feb20 19:15:12 - (001507) 150 Opening BINARY mode data connection for Router.rsc.
    [4] Mon 10Feb20 19:15:12 - (001507) Received file e:\backup\server\clients-internet-backup\mikrotik\Router.rsc successfully (0 Bytes/sec - 0 Bytes)
    [6] Mon 10Feb20 19:15:12 - (001507) 226 Transfer complete.
    [5] Mon 10Feb20 19:15:13 - (001507) Closing connection for user MIKROTIK (00:00:01 connected)
     
    Последнее редактирование: 10 фев 2020
  4. Илья Князев

    Илья Князев Администратор Команда форума

    У юзера под которым скрипт обрабатывается какие права?
     
  5. Roman Markov

    Roman Markov Участник

    Права "FULL" юзера, который Owner, а Policy ниже.

    Установка всех галок ситуации не меняет.
    Микротики пробовал разные.




    upload_2020-2-11_11-12-34.png
     
  6. Roman Markov

    Roman Markov Участник

    У меня есть подозрения, что в режиме скриптов как-то криво отрабатывается PassiveMode, но вроде бы нет параметра, заставляющего использовать FTP в ActiveMode...
     
  7. Илья Князев

    Илья Князев Администратор Команда форума

    Попробуйте на глобальный форум обратиться на английском. Там сами разрабы бывают.