Capsman со шлюзом на другом устройстве

Тема в разделе "Беспроводные технологии", создана пользователем SCRol, 24 окт 2018.

  1. SCRol

    SCRol Новый участник

    Всем привет!
    Столкнулся с интересной проблемой и не понимаю, где затык.
    Настроен капсман (без локального форвардинга). Сети, вещаемые на точках попадают на нем в свои бриджи. Все работает.
    Захотелось использовать капсман не в роли шлюза а чисто как контролер, чтобы клиенты выходили в интернет через сторонний шлюз.

    Схема проста до боли:
    Капсман (на CHR) - Шлюз (на CHR) - Интернет.

    Между капсманом и шлюзом проброшены виланы, в которые попадают беспроводные клиенты из разных сетей.
    Если шлюзом для клиента указывать интерфейс на капсмане - все ок.
    А вот если шлюзом я указываю IP адрес в той же вилане НО НА ШЛЮЗЕ (создан интерфейс в нужной вилане и ему присвоен IP адрес из той-же сети что и клиенты) - ничего не получается.
    Замечен интересный факт - со стороны шлюза при просмотре таблицы мак адресов в конкретной вилане - со стороны капсмана виден только один адрес - адрес бриджа. Такое ощущение, что капсман "прячет" все мак адреса клиентов беспроводных сетей, а светит наружу только свой бриджовый.
    Может кто сталкивался с подобным? Есть какие то решения? В принципе, ликвидация локал форвардинга на капсмане и пробрасывание нужных вилан до точек должно решать проблему, но хотелось бы трафик пускать через центр.
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Версия RouterOS какая?
     
  3. SCRol

    SCRol Новый участник

    v.6.42.9 long term
    Схема сети во вложении.
     

    Вложения:

  4. Илья Князев

    Илья Князев Администратор Команда форума

    Хм, не готов ответить, но ситуация странная.
     
  5. spooler

    spooler Новый участник

    Илья, добрый день,
    пересобрали стэнд

    на шлюзе подняты интерфейсы VLAN:
    int VLAN 1036 - 172.19.36.1 255.255.255.0
    int VLAN 1037 - 172.19.37.1 255.255.255.0
    int VLAN 1038 - 172.19.38.1 255.255.255.0



    на ether2 CHR (capsman) приходит транк от шлюза (vlan 1036, vlan 1037, vlan 1038)
    1036 - для управления точками
    1037 - тестовая сеть 1 для беспроводных клиентов - test_net_1
    1038 - тестовая сеть 2 для беспроводных клиентов - test_net_2


    ниже текущий конфиг капсмана и точки:

    capsman

    Код:
    /caps-man security
    add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=test_net passphrase=password
    
    /caps-man datapath
    add arp=enabled bridge=bridge_test client-to-client-forwarding=no local-forwarding=no name=test_net_1 vlan-id=1037 vlan-mode=use-tag
    add arp=enabled bridge=bridge_test client-to-client-forwarding=no local-forwarding=no name=test_net_2 vlan-id=1038 vlan-mode=use-tag
    
    /caps-man channel
    add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled frequency=2412 name=2G_channel_01 tx-power=20
    add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=disabled frequency=5180 name=5G_channel_36 skip-dfs-channels=yes tx-power=15
    
    /caps-man configuration
    add channel=2G_channel_01 datapath=test_net_1 mode=ap name=cfg_2G_test_net_1 rx-chains=0,1 security=test_net ssid=test_net_1 tx-chains=0,1
    add channel=5G_channel_36 datapath=test_net_1 mode=ap name=cfg_5G_test_net_1 rx-chains=0,1 security=test_net ssid=test_net_1 tx-chains=0,1
    add channel=2G_channel_01 datapath=test_net_2 mode=ap name=cfg_2G_test_net_2 rx-chains=0,1 security=test_net ssid=test_net_2 tx-chains=0,1
    add channel=5G_channel_36 datapath=test_net_2 mode=ap name=cfg_5G_test_net_2 rx-chains=0,1 security=test_net ssid=test_net_2 tx-chains=0,1
    
    /caps-man provisioning
    add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=cfg_2G_test_net_1 name-format=identity slave-configurations=cfg_2G_test_net_2
    add action=create-dynamic-enabled hw-supported-modes=an master-configuration=cfg_5G_test_net_1 name-format=identity slave-configurations=cfg_5G_test_net_2
    
    /caps-man manager
    set enabled=yes
    
    /caps-man interface
    add channel=2G_channel_01 configuration=cfg_2G_test_net_1 datapath=test_net_1 disabled=no l2mtu=1600 mac-address=CC:2D:E0:AA:10:CD /
    master-interface=none name=cap2G-test_net_1 radio-mac=CC:2D:E0:AA:10:CD security=test_net
    add channel=2G_channel_01 configuration=cfg_2G_test_net_2 datapath=test_net_2 disabled=no l2mtu=1600 mac-address=CC:2D:E0:AA:10:CD /
    master-interface=cap2G-test_net_1 name=cap2G-test_net_2 radio-mac=00:00:00:00:00:00 security=test_net
    add channel=5G_channel_36 configuration=cfg_5G_test_net_1 datapath=test_net_1 disabled=no l2mtu=1600 mac-address=CC:2D:E0:AA:10:CC /
    master-interface=none name=cap5G-test_net_1 radio-mac=CC:2D:E0:AA:10:CC security=test_net
    add channel=5G_channel_36 configuration=cfg_5G_test_net_2 datapath=test_net_2 disabled=no l2mtu=1600 mac-address=CC:2D:E0:AA:10:CC /
    master-interface=cap5G-test_net_1 name=cap5G-test_net_2 radio-mac=00:00:00:00:00:00 security=test_net
    
    /interface ethernet
    set [ find default-name=ether2 ] advertise=1000M-full comment=TRUNK_from_GATEWAY
    
    /interface bridge
    add fast-forward=no name=bridge_test protocol-mode=none vlan-filtering=yes
    
    /interface vlan
    add comment=managment_AP interface=bridge_test name=vlan1036-bridge_test vlan-id=1036
    add comment=test_net_1 interface=bridge_test name=vlan1037-bridge_test vlan-id=1037
    add comment=test_net_2 interface=bridge_test name=vlan1038-bridge_test vlan-id=1038
    
    /interface bridge port
    add bridge=bridge_test interface=ether2
    
    /interface bridge vlan
    add bridge=bridge_test tagged=ether2,bridge_test vlan-ids=1036
    add bridge=bridge_test tagged=ether2,bridge_test vlan-ids=1037
    add bridge=bridge_test tagged=bridge_test,ether2 vlan-ids=1038
    
    /ip address
    add address=172.19.36.254/24 interface=vlan1036-bridge_test network=172.19.36.0
    add address=172.19.37.254/24 interface=vlan1037-bridge_test network=172.19.37.0
    add address=172.19.38.254/24 interface=vlan1038-bridge_test network=172.19.38.0
    точка, получает адрес 172.19.36.11/24

    Код:
    # model = RouterBOARD wAP G-5HacT2HnD
    
    /interface ethernet
    set [ find default-name=ether1 ] speed=100Mbps
    
    /interface wireless
    # managed by CAPsMAN
    # channel: 2412/20/gn(20dBm), SSID: test_net_1, CAPsMAN forwarding
    set [ find default-name=wlan1 ]
    # managed by CAPsMAN
    # channel: 5180/20/ac(15dBm), SSID: test_net_1, CAPsMAN forwarding
    set [ find default-name=wlan2 ]
    
    /interface wireless cap
    set caps-man-addresses=172.19.36.254 discovery-interfaces=ether1 enabled=yes interfaces=wlan1,wlan2
    
    /ip dhcp-client
    add dhcp-options=hostname,clientid disabled=no interface=ether1
    
     
  6. spooler

    spooler Новый участник

    схема
     

    Вложения: