CAPsMAN + VLAN на одном устройстве. Клиенты не получают IP.

Тема в разделе "Вопросы начинающих", создана пользователем HeyHo~, 20 июл 2021 в 15:45.

  1. HeyHo~

    HeyHo~ Новый участник

    Прошу подсказать что делаю не так.

    Изначально имею RB4011 как центральный роутер с несколькими CAP AC. На роутере настроен capsman с двумя сетями и виланами. Точки подключаются к контроллеру и работают прекрасно. Но, клиенты, которые подключаются непосредственно к роутеру (а он тоже имеет wifi и тоже управляется через capsman) не получают IP.

    Взял hAP AC с дефолтной конфигурацией, настроил по аналогии и получил ту же самую ошибку.

    Подскажите пожалуйста, что я не донастроил?

    Код:
    # model = RBD52G-5HacD2HnD
    
    /caps-man channel
    add band=2ghz-b/g/n frequency=2447 name=2.4
    add band=5ghz-a/n/ac frequency=5180 name=5
    
    /interface bridge
    add admin-mac=74:4D:28:E5:0B:FF auto-mac=no comment=defconf name=bridge
    add name=bridge26
    
    /interface wireless
    # managed by CAPsMAN
    # channel: 2447/20-eC/gn(17dBm), SSID: 332123, local forwarding
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
        disabled=no distance=indoors frequency=auto installation=indoor mode=\
        ap-bridge ssid=MikroTik-E50C03 wireless-protocol=802.11
    # managed by CAPsMAN
    set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
        20/40/80mhz-XXXX distance=indoors frequency=auto installation=indoor \
        mode=ap-bridge ssid=MikroTik-E50C04 wireless-protocol=802.11
    
    /caps-man datapath
    add bridge=bridge26 client-to-client-forwarding=yes local-forwarding=yes \
        name=datapath26 vlan-id=26 vlan-mode=use-tag
    
    /caps-man security
    add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm \
        name=security26 passphrase=123456788
    
    /caps-man configuration
    add channel=2.4 country=russia datapath=datapath26 datapath.vlan-id=26 \
        datapath.vlan-mode=use-tag mode=ap name=2.4 rx-chains=0,1,2 security=\
        security26 ssid=332123 tx-chains=0,1,2
    add channel=2.4 country=russia datapath=datapath26 datapath.vlan-id=26 \
        datapath.vlan-mode=use-tag installation=indoor mode=ap name=5 rx-chains=\
        0,1,2 security=security26 ssid=332123 tx-chains=0,1,2
    
    /caps-man interface
    add configuration=2.4 configuration.mode=ap configuration.ssid=eer disabled=\
        no mac-address=00:00:00:00:00:00 master-interface=none name=cap26 \
        radio-mac=00:00:00:00:00:00 radio-name=""
    
    /interface list
    add comment=defconf name=WAN
    add comment=defconf name=LAN
    
    /interface wireless security-profiles
    set [ find default=yes ] supplicant-identity=MikroTik
    
    /ip pool
    add name=default-dhcp ranges=192.168.88.10-192.168.88.254
    add name=pool26 ranges=192.168.26.10-192.168.26.50
    
    /ip dhcp-server
    add address-pool=default-dhcp disabled=no interface=bridge name=defconf
    add address-pool=pool26 disabled=no interface=bridge26 name=dhcp26
    
    /caps-man manager
    set enabled=yes
    
    /caps-man provisioning
    add action=create-dynamic-enabled master-configuration=2.4 name-format=\
        prefix-identity name-prefix=2g
    add action=create-dynamic-enabled master-configuration=5 name-format=\
        prefix-identity name-prefix=5g
    
    /interface bridge port
    add bridge=bridge comment=defconf interface=ether2
    add bridge=bridge comment=defconf interface=ether3
    add bridge=bridge comment=defconf interface=ether4
    add bridge=bridge comment=defconf interface=ether5
    add bridge=bridge comment=defconf interface=wlan1
    add bridge=bridge comment=defconf interface=wlan2
    
    /ip neighbor discovery-settings
    set discover-interface-list=LAN
    /interface list member
    add comment=defconf interface=bridge list=LAN
    add comment=defconf interface=ether1 list=WAN
    add interface=cap26 list=LAN
    
    /interface wireless cap
    #
    set bridge=bridge caps-man-addresses=127.0.0.1 enabled=yes interfaces=\
        wlan1,wlan2
    
    /ip address
    add address=192.168.88.1/24 comment=defconf interface=bridge network=\
        192.168.88.0
    add address=192.168.26.1/24 interface=bridge26 network=192.168.26.0
    
    /ip dhcp-client
    add comment=defconf disabled=no interface=ether1
    
    /ip dhcp-server network
    add address=192.168.26.0/24 dns-server=192.168.88.1 gateway=\
        192.168.26.1 wins-server=192.168.88.1
    add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
    
    /ip dns
    set allow-remote-requests=yes
    
    /ip dns static
    add address=192.168.88.1 comment=defconf name=router.lan type=A
    
    /ip firewall filter
    add action=accept chain=input comment=\
        "defconf: accept established,related,untracked" connection-state=\
        established,related,untracked
    add action=drop chain=input comment="defconf: drop invalid" connection-state=\
        invalid
    add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
    add action=accept chain=input comment=\
        "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
    add action=drop chain=input comment="defconf: drop all not coming from LAN" \
        in-interface-list=!LAN
    add action=accept chain=forward comment="defconf: accept in ipsec policy" \
        ipsec-policy=in,ipsec
    add action=accept chain=forward comment="defconf: accept out ipsec policy" \
        ipsec-policy=out,ipsec
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
        connection-state=established,related
    add action=accept chain=forward comment=\
        "defconf: accept established,related, untracked" connection-state=\
        established,related,untracked
    add action=drop chain=forward comment="defconf: drop invalid" \
        connection-state=invalid
    add action=drop chain=forward comment=\
        "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
        connection-state=new in-interface-list=WAN
    
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" \
        ipsec-policy=out,none out-interface-list=WAN
    
    /tool mac-server
    set allowed-interface-list=LAN
    
    /tool mac-server mac-winbox
    set allowed-interface-list=LAN
    
     
    Последнее редактирование: 20 июл 2021 в 15:50