Черный экран на некоторых сайтах

Тема в разделе "Вопросы начинающих", создана пользователем uaz236, 23 июл 2017.

  1. uaz236

    uaz236 Новый участник

    Всем привет, уже как год борюсь с проблемой, пользователи жалуются что на чат рулетках всяческих, чёрный экран у собеседника.Проблему диагностировал, и на другом свиче допустим тплинка такой проблемы нет.
    провайдер билайн спб, всякие тоннели и прочее работает хорошо но что это за беда не поиму, погуглив уточнил, многие с такой бедой сталкиваются.

    вот конфигурация которую использовал для создания подключения.
    /interface l2tp-client
    add add-default-route=yes allow=chap,mschap2 connect-to=tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=XXXXX user=XXXXXXX
    /ip dhcp-client
    add default-route-distance=1 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=Beeline
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    В /ip firewall mangle правила с change-mss есть?
     
  3. uaz236

    uaz236 Новый участник

    /ip firewall mangle add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1453-65535
    да, вот они
     
  4. Илья Князев

    Илья Князев Администратор Команда форума

    Попробуйте
    /ip firewall mangle
    add action=clear-df chain=forward
     
  5. uaz236

    uaz236 Новый участник

    Cпасибо Илья, попробовал разные варианты как с добавлением новой позиции в текущую конфигурацию и изменением change-mss на clear df.
    результат около нулевой, в принципе может какой лог собрать?
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

    Проверьте пингом с разным размером пакета.
    У меня как-то такая штука была, когда подохла сетевая карта и пропускала пакеты до 1кб .
     
  7. uaz236

    uaz236 Новый участник

    Все бестолку, уже другой свич взял микротиковский, таже халера.
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

    Версия RouterOS какая?
     
  9. uaz236

    uaz236 Новый участник

    6.40.2, забегая вперед скажу что версии OS обновляю регулярно как появляется.
    есть у меня идея что какой-то протокол мультимедийный режется свичем(какие то порты блочатся и все тут) не эксперт но возможно в этом есть истина.
    может какой скриптик сделать для теста портов и поглядеть что будет?
    ps, подозреваю что это происходит из-за провайдера и каких-то внутренних несогласований.
    За поддержку огромное спасибо!
     
    Последнее редактирование: 25 авг 2017
  10. Илья Князев

    Илья Князев Администратор Команда форума

    Да не должно вроде. На TPLink же работает...
     
  11. uaz236

    uaz236 Новый участник

    В том и суть, предполагаю что именно с этим оператором такая вот странная особенность, но меняться с микротика на какой-то велосипед собранный из костылей (dd-wrt) на линк сисе, не хочется.
    может подскажете что "потестить" чтобы всеже расковырять этот баг.
    Заранее благодарен!
     
  12. Денис Друженков

    Денис Друженков Администратор

    Просто как временное решение:
    Попробуйте создать какой-нить туннель, и пустить именно этот трафик (для этих страниц) идет через него, и посмотреть что получиться. Может улучшить дело.
     
  13. uaz236

    uaz236 Новый участник

    Спасибо, попробую!