CLI - Нужна помощь...

Тема в разделе "Общие вопросы", создана пользователем Alex-bootton, 12 янв 2020.

  1. Alex-bootton

    Alex-bootton Новый участник

    Всем привет , нужна помощь по командам CLI ....

    Суть проблемы , нужно реализовать команду :
    tool ping-speed address=8.8.8.8
    с последующем сохранением в файл , но при сохранении файла , он или пустой , или не полностью отработан по выставленному времени .
    Не могу понять как поставить задержку для полного завершения команды по времени , и только потом сохранение в файл .....

    Задача стоит такая : нужно что бы в определенное время запускалась некая диагностика , например шлюза провайдера , и данные отправлялись на почту в виде файла или сообщения , это не важно , главное что бы данная команда отработала полностью ....
    Интересуют команды :
    1. ping-speed
    2. speed-test
    3. traceroute


    Заранее всем спасибо кто ответит =)
     
  2. Alex-bootton

    Alex-bootton Новый участник

    Странно как то у Вас тут ..... Форум заброшен ? Или я что то не так сделал !?

    Остановился на следующих командах :

    1.
    /tool ping-speed 8.8.8.8 second-ping-size=128 once duration=30 file=Ping.txt

    Но суть та же , команда выполняется не 30 сек , а гораздо меньше .....

    И второй вариант , более продвинутый , но так же нет задержки для выполнения данного теста.....

    :local info [/system resource monitor]
    :local ping [ping count=5 interval=100ms 8.8.8.8];
    :delay 10;
    #read log
    :local logcontent
    :foreach int in=[/log find ] do={
    :set logcontent ("$logcontent\r\n" .[/log get $int time]. " - " .[/log get $int message])
    }
    :log info $info
    :log info $ping
    :local ping ($ping->"ping")
    :log info $info
    :put [:time {:for i from=1 to=10 do={ :delay 100ms }}];
    :set log
    ###read log
    :local logcontent
    :foreach int in=[/log find ] do={
    :set logcontent ("$logcontent\r\n" .[/log get $int time]. " - " .[/log get $int message])
    }
    :delay 1;
    :log info $int
    #send email
    #/tool e-mail send to="XXXX@gmail.com" subject=([/system identity get name] . " Log " . [/system clock get date]) body=$logcontent

    В связи с этим ,
    Прошу подсказку какую команду и куда внедрить , что бы команды выполнялась указанное время ..... ?