iptv и microtik как wifi клиент

Тема в разделе "Беспроводные технологии", создана пользователем initoff, 27 янв 2016.

  1. initoff

    initoff Новый участник

    mikrotik mAP2n настроен как wifi клиент в домашней локалке, к нему подключена ТВ приставка с IPTV
    все порты и wlan в бридже, как научить микротик пропускать через себя трафик multicast, с настройками основного роутера микротик и wifi все в по идее в порядке, т.к. если в качестве wifi клиента использовать банальный tp link tl-wa801nd, то iptv работает без проблемна головном роутере настроен igmp proxy, и по проводам все ок...
    спасибо.

    /interface bridge
    add name=bridge-local
    /interface ethernet
    set [ find default-name=ether2 ] master-port=ether1
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no distance=indoors frequency-mode=\
    regulatory-domain mode=station-pseudobridge multicast-helper=full ssid=winter2 \
    wireless-protocol=802.11
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm \
    mode=dynamic-keys unicast-ciphers=tkip,aes-ccm wpa2-pre-shared-key=1357924680
    /ip hotspot profile
    set [ find default=yes ] html-directory=flash/hotspot
    /interface bridge port
    add bridge=bridge-local interface=ether1
    add bridge=bridge-local interface=wlan1
    /ip dhcp-client
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=bridge-local
    /system clock
    set time-zone-name=Europe/Moscow
    /system leds
    set 3 interface=wlan1
    /system routerboard settings
    set cpu-frequency=400MHz
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Установить пакет multicast. Настроить.
    Обратите внимание, что multicast в WiFi передается на Base Rates.
     
  3. initoff

    initoff Новый участник

    ок. но можно ли поподробнее? как настроить мультикаст, если все интерфейсы в бридже?
    если бы был wan/lan то там все понятно. я пробовал. и да. так работает. но как настроить мультикаст в этой ситуации?
    и мне не знакомо, что значит мультикаст по вайфаю в base rates?
     
  4. Илья Князев

    Илья Князев Администратор Команда форума

    А, все, понял. Неверно прочитал задачу.
    На клиенте, режим wireless-интерфейса должен быть station-bridge.
     
  5. initoff

    initoff Новый участник

    а при стейшн бридж, тик не коннектится к вафле, постоянно отваливается, соответственно не получает dhcp, получилось подключиться к вайфай только в режимах псевдобридж и псевдобридж клон
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

    А... Центральная не микротик. Понятно.
    Там фишка в том, что у стандартно через WiFi невозможно прогнать несколько MAC-ов. Пробуйте Pseudobridge. Там варианта
    Station Pseudobridge - все MAC-и "Натятся" в MAC wireless интерфейса.
    Station Pseudobridge Clone - Wireless-интерфейс переподключается каждый раз с MAC-ом того хоста, которому нужна передача.
     
  7. initoff

    initoff Новый участник

    Вот опять не понял. Псевдобридж и так стоит. И не работает. С псевдобридж клон впрочем тоже.
    Так что сделать? Что то дополнительно настроить?
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

    Кажется я уже не понимаю. Рисуйте схему что у вас и куда...
     
  9. initoff

    initoff Новый участник

    Ок. Тогда завтра набросаю.
     
  10. initoff

    initoff Новый участник

    нарисовал
    [​IMG]
    1. основной роутер mikrotik rb2011uias, все порты кроме wan в бридже. стоит пакет мультикаст, апстрим с wan, и отдача в бридж.

    2. iptv приставка провайдера, по кабелю работает. все ок.

    3. Linksys EA6700 используется как точка вайфай, wan не подключен

    4. MikroTik mAP 2n, наша проблема, вайфай клиент, подключается к linksys. wlan и eth в бридже. полный понфиг есть в первом посте

    5. iptv приставка провайдера, получает dhcp от основного роутера, интерфейс и список каналов прогружается, видеопотока нет.
     
  11. Илья Князев

    Илья Князев Администратор Команда форума

    Как вариант:
    1. Уберите WiFi из бриджа на mAP
    2. Поднимите eoip-туннель между mAP и 2011
    3. Создайте бридж между eoip и eth на mAP
    4. Направьте iptv в eoip на 2011
     
    bodun_off нравится это.
  12. initoff

    initoff Новый участник


    интересный костыль) мне бы даже в голову такое не пришло) обязательно попробую, отпишусь))
    это канешн лучше чем mAP как роутер поднимать) интересней) и мультикаст везде шарить не будет)
    но это частный вариант... когда во главе еще один Тик... более был бы интересен вариант решения проблемы локально в mAP. вот предположим что вместо Тика 2011, стоит ростелекомовский d-link с gpon, что делать тогда?

    на счет вашего варианта вроде все понял, с eoip дела еще не имел, но мануалы вроде видел, попробую разобраться. Но моих знаний не хватает в том что бы сообразить как сделать dhcp на eoip(поднимать еще один dhcp сервер? еще один локальный адрес Тику 2011? или), возможно ли использовать тот же пул адресов что и основной? и будут ли основной бридж и eoip видеть друг друга, а если нет, как это сделать?
     
  13. Илья Князев

    Илья Князев Администратор Команда форума

    Ничего. Бриджинг на WiFi в стандарт 802.11 не заложен.
    eoip по большой идее обычный ethernet-интерфейс. Т.е. вешаем на него адрес и далее dhcp setup. А нужно? В предлагаемом варианте, мы "притягиваем" ethernet mAP на 2011.
    Воткните eoip в бридж. Но тогда мультикаст пойдет везде.

    PS.
    Могу еще для развития воображения такой вариант вместо eoip предложить
    http://wiki.mikrotik.com/wiki/Transparently_Bridge_two_Networks_using_MPLS
     
  14. initoff

    initoff Новый участник

    вот этот момент вообще не понял, если не затруднит по подробнее.

    с бриджем то да, эт понятно, возможно ли это как то сделать без бриджа?

    обязательно займусь на досуге.

    но в моей голове все равно не укладывается такой момент: почему банальный tp-link, который в силу своей "тупости" пихает весь трафик куда тока может, без всяких настроек справляется с поставленной задачей, а на Тике приходится устраивать такие пляски с бубном?

    ps: все сертификаты преподаете вы, или только определенные?
     
  15. Илья Князев

    Илья Князев Администратор Команда форума

    В WiFi Security Association образуется между двумя мак-адресами. Т.е. Точка доступа не принимает данные, если MAC не равен MAC-у клиента.
    Для того, чтобы это обойти используются всяческие Wireless Extension.
    Если бы у вас WiFi был с другой стороны на микротике, у вас все бы заработало "из коробки".
    Надо посмотреть от какого MAC-адреса приходит этот трафик. Скорее всего используется Pseudobridge, только вы этого не видите.
    Все, кроме тренера. Тренера только сам микротик преподает.
     
  16. Turpa

    Turpa Новый участник

    то есть TP-Link в режиме Pseudobridge это может а Mikrotik нет?
     
  17. Илья Князев

    Илья Князев Администратор Команда форума

    Микротик тоже может. Режим работы интерфейса Station Pseudobridge, если AP не микротик и Staion Bridge если микротик.
     
  18. Turpa

    Turpa Новый участник

    Нет, не может..и мне абсолютно не понятно почему...
    Тут целый трэд об этом.
     
    Последнее редактирование: 23 янв 2017
  19. Илья Князев

    Илья Князев Администратор Команда форума

    Замените линксис на микротик. Проблема ИМХО со стороны него.
     
  20. Turpa

    Turpa Новый участник

    у меня есть такая схема на Cisco и такая же на ZyXel, так вот никакие Микротики не работают в них в режиме wifi моста с мультикастом. ТР-link -работает. Думаю что дело в коде вендора.