как подключится к IP камере через MikroTik RB2011UAS-2HnD-IN

Тема в разделе "Вопросы начинающих", создана пользователем alex2015, 26 окт 2015.

  1. alex2015

    alex2015 Новый участник

    Всем привет. Ситуация следующая, если в браузере набрать 192.168.88.246:37444/index.htm то подключаюсь к вэб интерфейсу камеры ввожу пароль и смотрю картинку, но если из интернета набирать свой статический адрес:37444 то доступа к камере нет, если порт убрать и просто зайти по айпи то выхожу на роутер свой, порт проверял открытый
    проброс порта делал так
    Chain – dstnat
    Dst.address – ваш внешний публичный статический адрес
    Protocol – tcp
    Dst. Port – внешний порт

    Action — Dst-nat
    To addresses – внутренний ip адрес (ip камеры)
    To рorts – порт на который происходит перенаправление(порт камеры 37444 )
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    У камеры настроен шлюз по умолчанию (default gateway) ?
    Нет ли у камеры ограничений доступа ?
     
  3. alex2015

    alex2015 Новый участник

    вот такие настройки у камеры, шлюз получается у неё на роутер указывает, кстати там в настройках на другой вкладке есть ещё порт 80, может его тоже надо прописать в роутере?
     

    Вложения:

    • 1.jpg
      1.jpg
      Размер файла:
      33,5 КБ
      Просмотров:
      24
    Последнее редактирование: 26 окт 2015
  4. vasilevkirill

    vasilevkirill Участник

    Часто в камерах надо еще прокидывать другие порты под потоки, посмотрите в документации какие все нужны порты, либо ловите их снифером.
     
  5. nikollor

    nikollor Новый участник

    Для просмотра потока в большинстве камер нужно открыть еще один-два порта, номера которых можно посмотреть и изменить в сетевых настройках камеры, но голая страница с запросом логина при проброшенном 80 порту откроется у всех камер.

    Собственно у меня та же проблема - есть свеженастроенный слабоизученный Микротик RB951Ui-2HnD c RouterOS 6.33.1, пытаюсь разобраться с пробросом портов.

    По доступным мануалам делаю проброс порта с dst-nat'ом или netmap'ом, вижу ровно ноль пакетов в счетчике. При этом в Filter Rules в accept'е того же порта вижу что пакеты из сети приходят. Где я косячу?
    sip2.PNG sip1.PNG
     

    Вложения:

    • sip2.PNG
      sip2.PNG
      Размер файла:
      16,3 КБ
      Просмотров:
      17
    • sip1.PNG
      sip1.PNG
      Размер файла:
      39 КБ
      Просмотров:
      17
  6. Илья Князев

    Илья Князев Администратор Команда форума

    Покажите /ip firewall nat export
    Можете заменить реальный IP на какой-нибудь 1.1.1.1
     
  7. nikollor

    nikollor Новый участник

    Код:
    [admin@mikrotik] > ip firewall nat export
    # feb/11/2016 13:30:55 by RouterOS 6.33.1
    # software id = XZFM-N4I1
    #
    /ip firewall nat
    add action=netmap chain=dstnat comment=Registrator dst-address=1.1.1.1 dst-port=3080 in-interface=\
        eth1-wan protocol=tcp to-addresses=192.168.0.170 to-ports=80
    add action=dst-nat chain=dstnat disabled=yes dst-port=6001-6003 in-interface=eth1-wan protocol=tcp to-addresses=\
        192.168.0.170
    add action=dst-nat chain=dstnat dst-port=5171 in-interface=eth1-wan log-prefix=nat_5171 protocol=udp \
        to-addresses=192.168.0.235 to-ports=5171
    add action=netmap chain=dstnat dst-port=5170 in-interface=eth1-wan protocol=tcp to-addresses=192.168.0.235 \
        to-ports=5170
    add action=masquerade chain=srcnat out-interface=eth1-wan src-address=192.168.0.0/24
    [admin@mikrotik] >
    
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

    Netmap немного не для этого предназначен.
     
  9. AlexSan

    AlexSan Новый участник

    Одного 80 порта мало пробрасывать наружу - обязательно 554(RTSP) и например у камер Hikvision нужен еще 8000 (сервисный) порт...
     
  10. nikollor

    nikollor Новый участник

    RTSP не всем камерам нужен. И не во всех случаях. Большинство камер выдают поток на CMS-ки и регисы с порта "media" (34567, 37777, 6001-6003 и прочие)

    Собственно, с моей стороны визуально разницы нет, что netmap, что dst-nat не работают. :( Что может быть не так?
     
  11. Илья Князев

    Илья Князев Администратор Команда форума

    Какие конкретно порты использует ваша камера?
     
  12. club777

    club777 Новый участник

    Такая же проблема, настраиваю чётко по https://toster.ru/q/183419
    добавил правило:
    add action=dst-nat chain=dstnat disabled=no dst-port=22554 protocol=tcp to-addresses=192.168.10.102 to-ports=22554
    - не работает!!!
    Пробовал уже всё что можно: менял protocol=tcp/udp и action=dst-nat/netmap (как рекомендуют тут: http://www.technotrade.com.ua/Articles/ ... arding.php), ничего не помогает, камеры по rtsp - недоступны... %)[​IMG]

    Может я где-то ступил? Может кто-то сталкивался с такой проблемой ?? Подскажите, пожалуйста, куда копать ??????







    На всякий случай /ip firewall nat export:
    # feb/16/2018 09:49:39 by RouterOS 6.41.2
    # software id = I449-W8D6
    #
    # model = 951Ui-2HnD
    # serial number = XXX
    /ip firewall nat
    add action=dst-nat chain=dstnat dst-port=22554 in-interface=WAN protocol=tcp to-addresses=192.168.10.102 to-ports=22554
    add action=masquerade chain=srcnat out-interface=WAN src-address=192.168.10.0/24
     
  13. Илья Князев

    Илья Князев Администратор Команда форума

    Если на правиле счетчики срабатывают - копайте камеру. В конфиге NAT ошибки не вижу.
     
  14. club777

    club777 Новый участник

    Проблема 100% на стороне Микротика, т.к. мы только сегодня переехали с D-Link на Mikrotik RB951Ui-2HnD, и на D-Link всё работает чётко!
    Да и в локалке всё работает на ура, видео без проблем открывается по ссылкам вида rtsp://192.168.10.102:22554/user=admin&password=ХХХ,
    а значит пароли/порты я не перепутал....)))
    А вот с заходом из интернета (по ссылке вида rtsp://ххх.ххх.ххх.ххх:22554/user=admin&password=ХХХ) - возникает проблема, так что это 100% виноват Микротик...:D
    Что-то не так! Помогите, пожалуйста, разобраться где я наплужил!!????? :D
     
  15. Илья Князев

    Илья Князев Администратор Команда форума

    Тогда давайте весь конфиг. Я не Коперфилд, чтобы угадать где там не так.
     
  16. club777

    club777 Новый участник

    Не нашел где у вас тут спойлер, сорри....))))

    config export:

    /export compact
    # feb/16/2018 10:20:29 by RouterOS 6.41.2
    # software id = I449-W8D6
    #
    # model = 951Ui-2HnD
    # serial number = XXXXXXXX
    /interface bridge
    add admin-mac=6C:3B:6B:E8:9B:8F auto-mac=no name=LAN
    /interface ethernet
    set [ find default-name=ether2 ] name="LAN1(2)"
    set [ find default-name=ether3 ] name="LAN2(3)"
    set [ find default-name=ether4 ] name="LAN3(4)"
    set [ find default-name=ether5 ] name="LAN4(5)"
    set [ find default-name=ether1 ] name=WAN
    /interface list
    add exclude=dynamic name=discover
    add name=mactel
    add name=mac-winbox
    /ip pool
    add name=dhcp ranges=192.168.10.10-192.168.10.200
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=LAN lease-time=23h59m59s name=DHCP
    /snmp community
    set [ find default=yes ] addresses=0.0.0.0/0
    /interface bridge port
    add bridge=LAN hw=no interface=WLAN
    add bridge=LAN interface="LAN1(2)"
    add bridge=LAN interface="LAN2(3)"
    add bridge=LAN interface="LAN3(4)"
    add bridge=LAN interface="LAN4(5)"
    /ip neighbor discovery-settings
    set discover-interface-list=discover
    /interface list member
    add interface=WLAN list=discover
    add interface="LAN1(2)" list=discover
    add interface="LAN2(3)" list=discover
    add interface="LAN3(4)" list=discover
    add interface="LAN4(5)" list=discover
    add interface=LAN list=discover
    add interface="LAN1(2)" list=mactel
    add interface=WLAN list=mactel
    add interface="LAN1(2)" list=mac-winbox
    add interface=WLAN list=mac-winbox
    add interface=WAN
    add interface=LAN list=mactel
    add interface=WAN
    /ip address
    add address=192.168.10.1/24 interface="LAN1(2)" network=192.168.10.0
    /ip dhcp-client
    add dhcp-options=hostname,clientid disabled=no interface=WAN use-peer-dns=no
    /ip dhcp-server lease
    add address=192.168.10.197 mac-address=EC:FA:BC:06:4C:7A server=DHCP
    add address=192.168.10.196 mac-address=2C:3A:E8:3B:6D:F9 server=DHCP
    /ip dhcp-server network
    add address=192.168.10.0/24 gateway=192.168.10.1
    /ip dns
    set cache-max-ttl=10m max-concurrent-tcp-sessions=25 query-server-timeout=4s query-total-timeout=12s servers=8.8.8.8,8.8.4.4
    /ip firewall filter
    add action=accept chain=input protocol=icmp
    add action=accept chain=input connection-state=established
    add action=accept chain=input connection-state=related
    add action=drop chain=input in-interface-list=!mactel
    /ip firewall nat
    add action=dst-nat chain=dstnat dst-port=22554 in-interface=WAN protocol=tcp to-addresses=192.168.10.102 to-ports=22554
    add action=masquerade chain=srcnat out-interface=WAN src-address=192.168.10.0/24
    /ip route
    add disabled=yes distance=1 gateway=255.255.255.0
    /ip upnp
    set enabled=yes
    /ip upnp interfaces
    add interface=LAN type=internal
    add interface=WAN type=external
    /system clock
    set time-zone-name=Europe/Paris
    /system identity
    set name="Mikrotik"
    /tool mac-server
    set allowed-interface-list=mactel
    /tool mac-server mac-winbox
    set allowed-interface-list=mac-winbox
     
  17. А что за модель камеры ? Правило NAT срабатывает когда пытаетесь подключиться из вне ? Счетчик пакетов увеличивается ?
     
  18. club777

    club777 Новый участник

    Проблема точно не в камере, т.к. по локалке всё работает,
    счётчик пакетов не увеличивается :D
     
  19. значит что-то не то, должен увеличиваться проброс не происходит.... Как проверяете ?
     
  20. Попробуйте пробросить WEB для начала