Микротик и QinQ

Тема в разделе "Маршрутизация", создана пользователем e_ludina, 13 янв 2016.

  1. e_ludina

    e_ludina Новый участник

    Добрый день, подскажите как можно организовать такую схему? -
    есть микротик rb2011
    1. нужно на 4 порт принять vlan565 в котором по технологии QinQ зашито 2 влана, 190 и 192
    2.отдать влан 190 и 192 тегом на порт 6
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Так принимайте. http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN#Q-in-Q
    Вопрос лишь в том, у вас там просто vlan в vlan-е или через 802.1ad (service-tag). Попробуйте так и так.
    А дальше бриджами скоммутируйте, что вам надо.
     
  3. Cup-of-tea

    Cup-of-tea Новый участник

  4. Илья Князев

    Илья Князев Администратор Команда форума

    Вешаете на интерфейс vlan.
     
  5. Cup-of-tea

    Cup-of-tea Новый участник

    я куди мне вкладивать vlan вголовний влан ?
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

    Код:
    /interface vlan
    add interface=Ether1 name=Main-vlan use-service-tag=yes vlan-id=100
    add interface=Main-vlan name=vlan-200 vlan-id=200
    
     
  7. Cup-of-tea

    Cup-of-tea Новый участник

    Що це за функція навіщо вона поясніть
    use-service-tag=yes
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

    Можно.
    Это функция обозначает сервисный VLAN для q-n-q в соответствии со стандартом 802.1ad
    Обратите пожалуйста внимание, что форум русскоязычный.
     
  9. Cup-of-tea

    Cup-of-tea Новый участник

    Єсли мне провайдер дал 123 vlan и я в него вложил 5 vlan's можу ли я принять на и другом интерфейсе например главным властно у меня будет главным 12
     
  10. Илья Князев

    Илья Князев Администратор Команда форума

    Если провайдер не поддерживает q-n-q может не заработать.
    Тогда поднимайте VPLS или EoIP и на него уже вешайте свои VLAN
     
  11. Cup-of-tea

    Cup-of-tea Новый участник

    если провайдер Предоставляем мне транковый интерфейс то мое оборудование упаковывает и распаковывает то почему оно должно не заработать
     
  12. Илья Князев

    Илья Князев Администратор Команда форума

    Зададим другой вопрос? А почему оно должно заработать?
    Как поведет себя операторский свитч, встретив в заголовке пакета неизвестный VLAN совершенно неясно. Обычно свитчи такие фреймы дропают.
     
  13. Cup-of-tea

    Cup-of-tea Новый участник

    Сприводу switch cisco я могу сказать с певненистю если в них непрописаты соответствующую команду то Q-in-Q незапрацюе а сприводу mikrotik я незнаю поэтому и спрашиваю
     
  14. Илья Князев

    Илья Князев Администратор Команда форума

    Микротику вообще без разницы. Он по умолчанию вообще все пропускает.
     
  15. Cup-of-tea

    Cup-of-tea Новый участник

    Их switch
    могут дропнуть мой пакет а могут и нет 50:50 если я правильно понял
     
  16. Илья Князев

    Илья Князев Администратор Команда форума

    Скорее дропнет чем нет. А почему бы вам не спросить это у провайдера?
     
  17. Cup-of-tea

    Cup-of-tea Новый участник

    написал он еще мне не ответил