Не работает Skype при подключенном PPTP/L2TP клиенте

Тема в разделе "Вопросы начинающих", создана пользователем romanchikov, 17 окт 2016.

  1. romanchikov

    romanchikov Новый участник

    Добрый день. Мои мысли иссякли, пришел просить о помощи.
    Есть два офиса. В первом офисе микротик с белым IP, во втором с серым.
    В первом офисе поднят pptp сервер. Второй микротик подключен клиентом. Мост поднят, пинги идут, шары, rdp работают.
    Но оказалось что во втором офисе не работает скайп. Ну и какие фунуции cms сайта.
    Отключаешь pptp соедениние, сразу все работает
    В маршрутах все просто. На клиенте
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 A S 0.0.0.0/0 94.159.67.141 1
    1 ADC 94.159.67.140/30 94.159.67.142 ether1-gateway 0
    2 S 192.168.0.0/24 pptp-out1 1
    3 S 192.168.0.0/24 192.168.6.2 192.168.6.1 1
    4 ADC 192.168.7.0/24 192.168.7.1 bridge-local 0

    Заменил PPTP на L2TP, без изменений.
    Куда копать, не понимаю
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    не совсем понимаю зачем вам 2 маршрута с одним назначением.
    Покажите экспорт конфигурации команда /export hide-sensitive
    Внешние адреса можете заменить на 1.1.1.1, 2.2.2.2 etc... Главное чтобы понятно было.
     
  3. romanchikov

    romanchikov Новый участник

    # oct/18/2016 03:17:41 by RouterOS 6.37.1
    # software id = XKKV-Q12G
    #
    /interface bridge
    add admin-mac=E4:8D:8C:B4:0D:FB auto-mac=no name=bridge-local
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-onlyn country=russia disabled=no \
    distance=indoors frequency=auto mode=ap-bridge ssid=Dan&Dani \
    wireless-protocol=802.11
    /interface ethernet
    set [ find default-name=ether1 ] name=ether1-gateway
    set [ find default-name=ether2 ] name=ether2-master-local
    set [ find default-name=ether3 ] master-port=ether2-master-local name=\
    ether3-slave-local
    set [ find default-name=ether4 ] master-port=ether2-master-local name=\
    ether4-slave-local
    set [ find default-name=ether5 ] master-port=ether2-master-local name=\
    ether5-slave-local
    /interface l2tp-client
    add connect-to=внешний ип первого офиса disabled=no name=l2tp-out1 user=L2TP
    /interface pptp-client
    add allow=mschap1,mschap2 connect-to=внешний ип первого офиса disabled=no name=pptp-out1 \
    user=most
    /ip neighbor discovery
    set ether1-gateway discover=no
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys
    add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=guest
    /interface wireless
    add disabled=no mac-address=E6:8D:8C:B4:0D:FF master-interface=wlan1 mode=\
    ap-bridge name=wlan2 security-profile=guest ssid="Dan&Dani's Guests"

    /ip ipsec proposal
    set [ find default=yes ] enc-algorithms=aes-128-cbc
    /ip pool
    add name=dhcp ranges=192.168.7.30-192.168.7.199
    add name=vpn ranges=192.168.89.2-192.168.89.255
    add name=dhcp_pool1 ranges=10.0.0.2-10.0.0.54
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=bridge-local lease-time=3d18h10m \
    name=default
    /ppp profile
    set *FFFFFFFE bridge=bridge-local local-address=192.168.89.1 remote-address=vpn
    /queue simple
    add burst-limit=1M/10M burst-time=30s/30s max-limit=1M/1M name=quests target=\
    wlan2
    add max-limit=5M/5M name=VPN target=pptp-out1
    /interface bridge filter
    # in/out-bridge-port matcher not possible when interface (wlan2) is not slave
    add action=drop chain=forward in-interface=wlan2
    # in/out-bridge-port matcher not possible when interface (wlan2) is not slave
    add action=drop chain=forward out-interface=wlan2
    /interface bridge port
    add bridge=bridge-local interface=ether2-master-local
    add bridge=bridge-local interface=wlan1
    add bridge=l2tp-out1 interface=wlan2
    /interface l2tp-server server
    set authentication=mschap1,mschap2 enabled=yes use-ipsec=yes
    /interface pptp-server server
    set enabled=yes
    /interface sstp-server server
    set default-profile=default-encryption enabled=yes
    /ip address
    add address=192.168.7.1/24 comment="default configuration" interface=\
    ether2-master-local network=192.168.7.0
    add address=94.159.67.142/30 interface=ether1-gateway network=94.159.67.140
    /ip cloud
    set ddns-enabled=yes
    /ip dhcp-client
    add comment="default configuration" dhcp-options=hostname,clientid interface=\
    ether1-gateway
    /ip dhcp-server lease
    add address=192.168.7.11 client-id=1:38:d5:47:b2:b0:a3 mac-address=\
    38:D5:47:B2:B0:A3 server=default
    add address=192.168.7.10 client-id=1:0:90:a9:ea:ec:9c mac-address=\
    00:90:A9:EA:EC:9C server=default
    add address=192.168.7.21 mac-address=EC:8E:B5:24:91:BF server=default
    add address=192.168.7.12 client-id=1:38:d5:47:b2:9d:23 mac-address=\
    38:D5:47:B2:9D:23 server=default
    add address=192.168.7.13 client-id=1:38:d5:47:b2:b2:86 mac-address=\
    38:D5:47:B2:B2:86 server=default
    add address=192.168.7.14 client-id=1:38:d5:47:b2:b1:3a mac-address=\
    38:D5:47:B2:B1:3A server=default
    add address=192.168.7.16 client-id=1:38:d5:47:b2:b0:e6 mac-address=\
    38:D5:47:B2:B0:E6 server=default
    add address=192.168.7.17 client-id=1:38:d5:47:b2:b0:a2 mac-address=\
    38:D5:47:B2:B0:A2 server=default
    add address=192.168.7.15 client-id=1:38:d5:47:b2:9d:10 mac-address=\
    38:D5:47:B2:9D:10 server=default
    add address=192.168.7.18 client-id=1:38:d5:47:b2:9c:b4 mac-address=\
    38:D5:47:B2:9C:B4 server=default
    add address=192.168.7.22 mac-address=EC:8E:B5:23:B2:41 server=default

    /ip dhcp-server network
    add address=192.168.7.0/24 comment="default configuration" gateway=192.168.7.1 \
    netmask=24
    /ip dns
    set allow-remote-requests=yes servers=93.92.32.93,93.92.33.92
    /ip dns static
    add address=192.168.7.1 name=router
    add address=192.168.7.10 name=cloud
    /ip firewall filter
    add action=accept chain=input comment="default configuration" protocol=icmp
    add action=fasttrack-connection chain=forward comment="default configuration" \
    connection-state=established,related
    add action=accept chain=input comment="default configuration" connection-state=\
    established,related
    add action=accept chain=input dst-port=8291 protocol=tcp
    add action=accept chain=input dst-port=80 protocol=tcp
    add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
    add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
    add action=accept chain=input comment="allow sstp" dst-port=443 protocol=tcp
    add action=accept chain=forward comment="default configuration" \
    connection-state=established,related
    add action=drop chain=input comment="default configuration" in-interface=\
    ether1-gateway
    add action=drop chain=forward comment="default configuration" connection-state=\
    invalid
    add action=drop chain=forward comment="default configuration" \
    connection-nat-state=!dstnat connection-state=new in-interface=\
    ether1-gateway
    /ip firewall nat
    add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=ether1-gateway
    add action=masquerade chain=srcnat out-interface=all-ppp
    add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
    192.168.89.0/24
    /ip route
    add distance=1 gateway=94.159.67.141
    add distance=1 dst-address=192.168.0.0/24 gateway=192.168.6.1 pref-src=\
    192.168.6.2
    add distance=1 dst-address=192.168.0.0/24 gateway=l2tp-out1
    /ip upnp
    set enabled=yes
    /ip upnp interfaces
    add interface=bridge-local type=internal
    add interface=ether1-gateway type=external
    /ppp secret
    add name=vpn
    /system clock
    set time-zone-name=Asia/Krasnoyarsk
    /system leds
    set 0 interface=wlan1
    /tool mac-server
    set [ find default=yes ] disabled=yes
    add interface=ether2-master-local
    add interface=wlan1
    add interface=wlan2
    /tool mac-server mac-winbox
    set [ find default=yes ] disabled=yes
    add interface=ether2-master-local
    add interface=wlan1
    add interface=wlan2
    [MTM@MikroTik] > ping 192.168.7.11
    [MTM@MikroTik] >
    [MTM@MikroTik] >
     
  4. Илья Князев

    Илья Князев Администратор Команда форума

    Вроде все более менее. Небольшие вопросы
    1. Зачем в ppp-профиле бридж и адреса
    2. Зачем маршрут
    add distance=1 dst-address=192.168.0.0/24 gateway=192.168.6.1 pref-src=192.168.6.2
    3. Зачем NAT на PPP, а не маршрутизация site-to-site
     
  5. romanchikov

    romanchikov Новый участник

    Добрый день. Спасибо за помощь.
    1. РРР профиль скорее всего от "штатного" VPN. Я его сам не настраивал
    2. Маршрут добавлял согласно статьи в WiKi. Без него небыло пинга в 192.168.0.0
    Если его отключить, то изменений нет никаких. Пинги идут, скайп не работает.
    3. Опять же штатный VPN скорее всего
     
    Последнее редактирование: 18 окт 2016
  6. Илья Князев

    Илья Князев Администратор Команда форума

  7. romanchikov

    romanchikov Новый участник

    Проблема решилась командной System reset-configuration