No-ip не работает с локальной сетью

Тема в разделе "Вопросы начинающих", создана пользователем alex-rudenkiy, 11 авг 2017.

  1. alex-rudenkiy

    alex-rudenkiy Новый участник

    Здравствуйте, сегодня подключил No-IP, сразу захотел проверить свою программу которая работает с tcp по 5665 порту, естественно есть Server и Client, всё работает хорошо (скрин приложил), только если подключаться в клиенте к localhost (запускаю со своего же компа) :5665, а если подключаться через INTERNET, то появляются какие-то проблемы, убил уже 2 дня, перечитал 999 статей по запросу "проброс портов" и "фильтрация", последняя надежда написать сюда :(

    Если кому-то интересно как я работаю с NO-IP, то вот скрипт :

    Код:
    # No-IP automatic Dynamic DNS update
    
    #--------------- Change Values in this section to match your setup ------------------
    
    :local noipuser "alexrudenkiy2014@gmail.com"
    :local noippass "СуперПуперМегаПароль"
    :local noiphost "alexserver.bounceme.net"
    
    # Change to the name of interface that gets the dynamic IP address
    :local inetinterface "ether1"
    
    #------------------------------------------------------------------------------------
    # No more changes need
    
    :if ([/interface get $inetinterface value-name=running]) do={
    # Get the current IP on the interface
      :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]
    
    # Strip the net mask off the IP address
      :for i from=( [:len $currentIP] - 1) to=0 do={
         :if ( [:pick $currentIP $i] = "/") do={
            :set currentIP [:pick $currentIP 0 $i]
         }
      }
    
    # The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
      :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
      :local noiphostarray
      :set noiphostarray [:toarray $noiphost]
     
      :foreach host in=$noiphostarray do={
        # Check 1 - resolved IP
        :local resolvedIP [:resolve $host];
    
        # Check 2 - Saved response from NO-IP
        :local filename ("no-ip_ddns_update-" . $host . ".txt")
        :local savedMatch -1
        :local savedIP "No File";
    
        if ( [:len [/file find name=$filename]] > 0 ) do={
          :set savedIP [/file get $filename contents]
          :set savedMatch [:find $savedIP $currentIP -1]
        }
    
        # If either check fails, update IP   
        :if (($currentIP = $resolvedIP) && ($savedMatch >= 0)) do={
          :log info "No-IP: Host $host already on No-IP with IP $resolvedIP"
        } else={
          :log info "No-IP: Sending update for $host - $resolvedIP saved as $savedIP"
          /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=$filename
          :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
        }
      }
    } else={
      :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
    }
    2017-08-11_20-12-21.png

    NAT Rule я сделал такой :

    Chain : dstnat
    Protocol : 6 (tcp)
    Dst. Port : 5665
    In. Interface : ether1

    Action : dst-nat
    To Addresses : 192.168.88.245 (адрес моего компа в локалке)
    To Ports : 5665
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Кто мешает воспользоваться бесплатным встроенным /ip cloud?
     
  3. alex-rudenkiy

    alex-rudenkiy Новый участник

    Извиняюсь заранее за тупой вопрос, а это что? Альтернативное подключение к No-IP или совсем другой сервис? И как тогда с ним работать, а то я посмотрел в интернете и только нашёл, что это какая-то новая функция в которой только одна галочка ""DDNS Enabled"?
     
    Последнее редактирование: 12 авг 2017
  4. Kato

    Kato Участник

  5. alex-rudenkiy

    alex-rudenkiy Новый участник

    Всё хорошо, но у меня постоянно Update и в конце концов Error: request timed out. Я как понимаю Public Address должен появиться сам по себе. Может для этой функции нужен статический IP адрес которого у меня нет и из-за которого в начале я подключался к No-IP (кстати к роутеру из WWW я подключался, но до локальной сети так не чего и не доходило)
     

    Вложения:

  6. alex-rudenkiy

    alex-rudenkiy Новый участник

    Кстати я вот только что сделал так : Запустил скрипт, затем запустил Cloud и у меня появилось :
    , что это значит? Если включать Cloud без скрипта, то постоянно update, ну короче то-что в предыдущем комментарии.
     
  7. alex-rudenkiy

    alex-rudenkiy Новый участник

    Я вот сейчас всё сбросил до заводских настроек решил просто Cloud включить, чтобы без Noip, но выводит туже длинную строку, странно с чем он конфликтует 0_o
     
  8. alex-rudenkiy

    alex-rudenkiy Новый участник

    Вот на данный момент у меня такая проблема http://mikrotik-ukraine.blogspot.ru/2016/09/ip-cloud-dynamic-dns-nat.html , сейчас пробую что-то сделать.

    Странно, запустил, а он пишет Mynetname: No update needed (93.157.144.66=93.157.144.66), типо не надо обновляться. Блин, самое обидное что не понятно в чём именно ошибка, в пробросе порта или в в получении этого ip адреса и получается страшная путаница.

    Я вот сейчас ещё попробовал подключиться из интернета (ноутбук подключённый через модем, то-есть не через wifi) к серверу и включил Packet Sniffer по порту 5665, то вообще глухо, не чего не приходит.

    Может всё таки лучше с No-IP попробовать, с ним хотя-бы в роутер можно было зайти из интернета, может там какого нибудь NAT правила не хватало?
     
    Последнее редактирование: 12 авг 2017
  9. Илья Князев

    Илья Князев Администратор Команда форума

    Это значит, что у вас нет внешнего IP-адреса. Т.е. вы находитесь за NAT провайдера.