обновление до RouterOS 6.37

Тема в разделе "Беспроводные технологии", создана пользователем restwed, 25 окт 2016.

  1. restwed

    restwed Новый участник

    Имеется аппарат Mikrotik 951G-2HnD
    После обновления до указанной в названии темы версии RouterOS перестали подключаться некоторые клиенты, в логах появляются следующие повторяющиеся сообщения:

    wlan1: reject <mac адрес устройства>, banned (last failure - recieved deauth: class 3 frame received (7))
    wlan1: <mac адрес устройства> attempts to associate

    на подключаемом устройстве в этот момент вылазит сообщение: "сбой подключения к WiFi"
    Проблема проявилась только на версии 6.37 (в 6.37.1 тоже самое) в которой что-то там проделали с объединением нескольких разных пакетов WiFi в один пакет под названием wireless.
    В предыдущих версиях все устройства подключались по wifi и работали нормально (и начнут подключаться, если 6.36 восстановить из backup'а)

    Очень надеюсь что гуру Mikrotik подскажут что надо посмотреть в настройках wlan или в методах шифрования.
    PS: понимаю что не написал никакой информации о настройках wlan и вопрос мой сродни просьбе о телепатии, но вдруг кто-то уже сталкивался с подобным поведением.
     
    Последнее редактирование: 25 окт 2016
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Хм. А в старой версии на каком пакете работали?
     
  3. restwed

    restwed Новый участник

    wireless-fp

    upd.: надо уточнить что подключаться перестали достаточно древние устройства: смартфон Philips W732 (wifi в нем 802.11n) и ноутбук HP Compac 6120c (в нем wifi стандарта B).
    Смартфон Sony M4 Aqua и планшет Google Nexus 7 2013 как подключались к беспроводной сети так и подключаются без проблем.
     
    Последнее редактирование: 25 окт 2016
  4. Илья Князев

    Илья Князев Администратор Команда форума

    Дайте вывод /interface wireless export
    Может чего увижу.
     
  5. restwed

    restwed Новый участник

    Вот конфиг:

    [restwed@MikroTik] > /interface wireless export
    # oct/26/2016 11:06:33 by RouterOS 6.37.1
    # software id = EXPH-ILGH
    #
    /interface wireless
    set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode band=2ghz-b/g/n channel-width=20/40mhz-Ce country=\
    russia2 default-authentication=no disabled=no distance=indoors frequency=auto frequency-mode=regulatory-domain \
    guard-interval=long hw-protection-mode=rts-cts mode=ap-bridge multicast-helper=disabled tx-power=17 tx-power-mode=\
    all-rates-fixed wireless-protocol=802.11 wmm-support=enabled
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys wpa-pre-shared-key=mypassword\
    wpa2-pre-shared-key=mypassword
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

    1. Порпобуйте явно задать канал. Желательно не крайний.
    2. Попробуйте увеличить мощность до 20DBm
     
  7. restwed

    restwed Новый участник

    Нет, к сожалению не помог ни первый, ни второй пункт.
    выбирал канал явно, перебирал несколько разных каналов 2432, 2437, 2442, 2447
    мощность увеличивал до 23 DBm

    Но теперь в логах немного другая ошибка:
    <mac адрес устройства>@wlan1: connected
    <mac адрес устройства>@wlan1: disconnected, received deauth: class 3 frame received (7)

    а на самом подключаемом устройстве сообщается об проблеме авторизации.
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

    На устройстве забыть сеть и заного ее найти пробовали?
     
  9. restwed

    restwed Новый участник

    да, это я делал в первую очередь, пробовал и возвращение смартфона к заводским настройкам..

    Раздобыл для тестирования аппарат Mikrotik hAP ac lite, проверю как у него обстоят дела с подключением стареньких устройств на версии 6.37.1
     
  10. restwed

    restwed Новый участник

    Заменил 951G-2HnD на взятый во временное пользование hAP ac lite, настройки дефолтные, лишь прописал пароль на точку доступа

    [admin@MikroTik] > /interface wireless export
    # oct/18/2016 19:09:01 by RouterOS 6.37.1
    # software id = HD6P-GKJG
    #
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country=russia \
    disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-D3F87E \
    wireless-protocol=802.11
    set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-Ce country=russia
    default-authentication=no disabled=no distance=indoors frequency=auto mode=ap-bridge s
    MikroTik-D3F87D wireless-protocol=802.11
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys \
    wpa-pre-shared-key=mypass wpa2-pre-shared-key=mypass

    результат тот же самый:
    <mac адрес устройства>@wlan1: connected
    <mac адрес устройства>@wlan1: disconnected, received deauth: class 3 frame received (7)

    все таки похоже что это глюк 6.37 версии. Пробовал установить релиз кандидат 6.38 - не полегчало.
    Уже и не знаю что думать, пока откатился на 6.36.4
     
  11. Hamlo

    Hamlo Новый участник

    Здравствуйте. Полностью аналогичная проблема.
    Новый (только купил) RB-951Ui-2HnD Прошивка 6.37.1
    Сначала вываливает про недостаточно ресурсов
    http://joxi.ru/LmGyN1zCGoKMAl
    Потом банит.
    http://joxi.ru/YmEy7xjCYOvbm6
    Телефон - старенький Philips W536
    При этом iphone 6s и ноутбуки прекрасно цепляются.
    Если выключить шифрование, то и старый телефон цепляется.
     
  12. Hamlo

    Hamlo Новый участник

    Откатил на 6.36.4 - настройки те же, всё заработало.
     
  13. Илья Князев

    Илья Князев Администратор Команда форума

    Пишите баг-репорт в Mikrotik
     
  14. ninjass

    ninjass Новый участник

    столкнулся с аналогичной проблемой =\ подскажите у микротика есть открытый баг репорт где бы можно было посмотреть существующий баги/обходные пути?
     
  15. Илья Князев

    Илья Князев Администратор Команда форума

    Официального открытого баг-трекера нет.
    Откатитесь на bugfix-only версию.
     
  16. sasha_ml

    sasha_ml Новый участник

    Абсолютна такая же проблема после обновления с 6.08. до 6.38.
    один старенький телефон перестал подключаться (с другими точками работает), все остальные wi-fi устройства работают как и раньше.

    в What's new in 6.39rc12 (http://www.mikrotik.com/download/changelogs/) в багфиксах есть строчка
    *) wireless - fixed rare wireless ac interface lockup;
    интересно это оно?
    Что-то на RC обновлятся не очень хочется, а полный релиз видимо через месяц- другой.
     
  17. Илья Князев

    Илья Князев Администратор Команда форума

    Вообще, если нет фич, которые нужны прямо кровь из носу, лучше сидеть на bugfix-ветке.
     
  18. denisa

    denisa Новый участник

    Обновился до 6.39.1 (2017-Apr-27 10:06). Старые устройства заработали!