PCQ queue как правильно настроить

Тема в разделе "Беспроводные технологии", создана пользователем ilin1982, 7 авг 2016.

  1. ilin1982

    ilin1982 Новый участник

    Добрый день!
    По умолчанию wireless работает с sfq очередью. Как я понимаю не самое эффективное решение для балансировки нагрузки точки. Много и не понятно в интернете написано про PCQ очередь и работу с помеченным трафиком. Если можно разъясните для тех кто в танке как же правильно и эффективно работать с этим типом очереди. Задача проста: есть точка из нее ethernetом трафик уходит в канал, соответственно на точке сидит порядка 10-15 (а в дальнейшем больше) клиентов, с торрентами, скайпами и т.д., соответственно нужно 100 м/бит раздать на всех текущих пользователей чтобы никого не обидеть, ну и точку не загнуть.
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    PCQ на интерфейс не повесить, потому что там надо делать две очереди в разных направлениях.
    Вам достаточно:
    1. Создать Simple queue
    2. В свойстве Target - подсеть с вашими юзерами (например 192.168.88.0/24)
    3. max-limit-download и max-limit-upload ставите в максимальную скорость для подсети (например 50m / 50m). Не ставьте 100 мбит. Их у вас реально нет и роутер не сможет попилить трафик корректно.
    4. Закладка Advanced. В Queue Type Upload и Queue Type Download выбираем типы pcq-upload-default и pcq-download-default.

    В общем-то и все.
     
    Vaippp нравится это.
  3. ilin1982

    ilin1982 Новый участник

    Пара вопросов:
    1. Почему нет 100? Канал в 100 м/бит. Или микрот не может 100 держать на wireless для клиентов?
    2. Тут немного о топологии конкретно моей сети, точки траф пропускают в бридж до DHCP. Ну а оттуда уже в магистраль до провайдера. См картинку (рисую так себе). Как в такой топологии реализовать? Не очень хочется кучу подсетей разводить.
    topol.jpg
     

    Вложения:

    • test.jpg
      test.jpg
      Размер файла:
      67,1 КБ
      Просмотров:
      6
  4. Илья Князев

    Илья Князев Администратор Команда форума

    То есть у вас есть ГАРАНТИРОВАННЫХ 100 мбит до инета?
     
  5. ilin1982

    ilin1982 Новый участник

    В тесте скорость от абонентской точки до netboxa который в инет смотрит. Инета 100 м/бит гарантированных (да не хило, но мне же нужно чтобы всем хватало, отсюда и следствие вопроса как же делить). Вся магистраль поэтому и построена по ac технологии, 100 м/бит на абон точку приходит только потому что у SXT lite 5 ac порт ethernet 100. В магистрали под 200 бегает. Между netboxами 16 км, между металами метров по 500.
     
  6. ilin1982

    ilin1982 Новый участник

    netbox используют pfifo очередь с 500 пакетами, все остальное оборудование пока sfq, дабы не знаю как лучше сделать. Вообще если подскажите как это все счастье посильнее разогнать, инета 200 м/бит смогу в сеть пустить.
     
  7. Илья Князев

    Илья Князев Администратор Команда форума

    PCQ работает только с IP-адресами. Можно сделать первоначальный вариант, который я вам предлагал.
    Вы утыкаетесь в 100мбит на интерфейсе. Что вы собрались разгонять?
     
  8. algerka

    algerka Новый участник

    Извините, может мой вопрос не в той теме, но похож. Мне надо разделить интернет на всех пользователей поровну.

    Подскажите,
    п.2 можно вместо подсети указать интерфейс?
    п.3 можно не указывать max-limit-download и max-limit-upload тогда вроде должно делить на всех поровну?

    Т.е достаточно такого правила?:
    /queue simple add name=equally queue=pcq-upload-default/pcq-download-default target=bridge-local
     
  9. Илья Князев

    Илья Князев Администратор Команда форума

    У нас есть некоторое неизвестное количество апельсинов. Надо поделить на всех поровну. Решаемая задача?
    Можно
     
  10. algerka

    algerka Новый участник

    И как быть, чтобы качальщики не забирали всю скорость? Запретить p2з нельзя. Просто у меня USB модем гарантированной скорости просто нет.

    А если трафику приоритет назначить через mangle, или без очереди с указанием скорости канала все равно не будет работать ?
     
  11. Илья Князев

    Илья Князев Администратор Команда форума

    Повесьте на interface queue очередь типа SFQ (посмотрите как wireless-default сделан)
    Чтобы приоритетный трафик начал выдавливать остальной, надо знать пропускную канала.
     
  12. algerka

    algerka Новый участник

    SFQ не спасет от торрент-качальщиков, т.к. он каждый поток рассматривает как отдельный без привязки к ip.
    PCQ больше подходит
     
  13. Илья Князев

    Илья Князев Администратор Команда форума

    Это не так. Там идет хеш
    src-address src-port dst-address port
     
  14. Chai

    Chai Новый участник

    Target - цель, а что такое Dst тогда? Чем они отличаются?
     
  15. Илья Князев

    Илья Князев Администратор Команда форума

    Target клиент. Фактически классификатор трафика. dst- конкретный сервер.
    Пример.
    Разрешить работать юзерам с подсети 192.168.88.0/24 c сервером 1.1.1.1 на скорости 10мбит и со всеми остальными на скорости 2 Мбит.
    Код:
    /queue simple
    add dst=1.1.1.1/32 max-limit=10M/10M name=queue1 target=192.168.88.0/24
    add max-limit=2M/2M name=queue2 target=192.168.88.0/24
    
     
  16. Mama

    Mama Участник

    Друзья, всем дня!

    Есть ip tv которое приходит по eoip, есть торрентокачалка. Запускаем торрент имеем артефакты в картинке iptv. Как эстетично разрулить?

    Заранее спасибо!
     
  17. Илья Князев

    Илья Князев Администратор Команда форума

    Попробуйте на LAN интерфейс повесить очередь wireless-default
     
    Mama нравится это.
  18. Mama

    Mama Участник

    )
    add action=mark-connection chain=forward new-connection-mark=up passthrough=yes src-address=192.168.11.0/24
    add action=mark-packet chain=forward connection-mark=up new-packet-mark=up passthrough=yes
    add action=mark-connection chain=forward dst-address=192.168.11.0/24 new-connection-mark=down passthrough=yes
    add action=mark-packet chain=forward connection-mark=down new-packet-mark=down passthrough=yes

    add disabled=yes max-limit=90M name=parent packet-mark=up,down parent=bridge1 queue=wireless-default

    Все верно?
     
  19. Илья Князев

    Илья Князев Администратор Команда форума

    Неа, все проще.
    Код:
    /queue interface set bridge-local queue=wireless-default
    Это заставит его на интересе пилить потоки SFQ
     
    Mama нравится это.
  20. Mama

    Mama Участник

    failure: non rate limit queues are useless on this interface

    порты в бридже должны быть?