Помогите новичку настроить микротик на два провайдера

Тема в разделе "Вопросы начинающих", создана пользователем Валерий, 11 окт 2015.

  1. Валерий

    Валерий Участник

    Что имеется в наличии:
    1) микротик RB951G-2HnD
    2) Рабочая станция с ПЦН Мираж
    3) Провайдер Мегафон (статический ip)
    4) Провайдер Солнце телеком (статический ip)
    Что необходимо получить в результате:
    1) Мегафон как основной провайдер
    2) Солнце телеком как резервный провайдер
    3) Переключение между провайдерами для стабильного интернет соединения
    4) Проброс портов 8000и 5000 с внешнего ip на внутренний ip
     
  2. vasilevkirill

    vasilevkirill Участник

    Показывайте, что уже сделали и в чём у вас затык.
     
  3. Валерий

    Валерий Участник

    Добрый день. спасибо, что решили ответить мне. Вообщем, никогда не сталкивался с таким роутером. Затык заключается в том, что даже интернет соединение поднять не получается, уже кучу видео и текста пересмотрел и все никак. Создаю в интерфейсе L2tp соединение, ввожу логин, пароль и строку vpn сервера. после этого появляется слева буква R насколько я знаю, это обозначает, что соединение есть. В статусе написано connection. Далее создаю DHCP сервер ввожу ip 192.168.0.0/24, а дальше-ничего нет. Подскажите, пожалуйста, что не так делаю.
     
  4. vasilevkirill

    vasilevkirill Участник

    Валерий, для того чтобы вам помочь, у вас должен быть опыт работы с сетями и хотя бы малейшее представление как работает NAT,DNS и маршрутизация.

    из того что вы написали следует вывод, что вы настроили всё правильно а вот "дальше-ничего нет", тут появляется вопрос а что вы хотите сделать?
    не совсем понятно для чего вам DHCP?
    не совсем понятно для чего вам L2tp?
    не совсем понятно что должно быть дальше!
     
  5. Валерий

    Валерий Участник

    у меня есть небольшой опыт работы с сетями. В основном я работал с D-LINK, TP-LINK и прочим китайским шерпотрепом. Микротик это совсем другая песня. Вообщем я тут схемку переделал под свой лад. Гляньте, может картинка проясниться.
     

    Вложения:

  6. vasilevkirill

    vasilevkirill Участник

    Более менее нормальная схема, всё ровно непонятно чего вы хотите добиться и не понятно что конкретно не получается настроить
     
  7. Валерий

    Валерий Участник

    Задача такая-хочу добиться бесперебойного интернета, чтоб при пропадании пинга на основном канале, микротик перебрасывал на резервный канал и при этом слушал основной канал, как только там появился пинг возвращал на основной канал.
    Вообщем с настройкой выхода в интернет я разобрался. теперь задача состоит в настройке вышеуказанного. Можете подсказать последовательность действий или какой-нибудь конкретный пример как это сделать и где что настроить.
     
  8. Валерий

    Валерий Участник

    для информации: контроллер МИРАЖ настроен таким образом, что при пропадании связи с сервером он автоматически переключается на резервный канал и пытается подсоединиться по нему, если не выходит то пробует по основному и так по кругу. Так что со стороны контроллера все работает нормально. Необходимо теперь настроить микротик примерно таким же образом.
     
  9. vasilevkirill

    vasilevkirill Участник

    Показывайте, где у вас затык
     
  10. Валерий

    Валерий Участник

    затык в голове. не знаю как настроить этот реверс. с чего начать и чем закончить
     
  11. vasilevkirill

    vasilevkirill Участник

    Начните с этого
     
  12. Валерий

    Валерий Участник

    Спасибо за статью, прочитал-умнее стал))) вопрос такой возник, чтоб компьютеры в локалке микротика получали автоматом ip-шники нужно создавать DHCP СЕРВЕР?
     
  13. vasilevkirill

    vasilevkirill Участник

    Не обязательно, вот например, как может получить ip host
     
  14. Валерий

    Валерий Участник

    Вот такая схема примитивная работать будет(стабильный интернет). при условии что порты проброшены, и все устройства находятся в одной подсети.
     

    Вложения:

    • 123.jpg
      123.jpg
      Размер файла:
      29,5 КБ
      Просмотров:
      11
  15. Валерий

    Валерий Участник

  16. vasilevkirill

    vasilevkirill Участник

    Валерий, вы пришли на форум, чтобы за вас всё сделали или всё же разобраться, как настроить тот или иной функционала на оборудовании MikroTik?
    Если первое, то либо ичите мат. часть и продвигайтесь ко второму варианту или пиши мне в личку
    Если второе, то пишите что конкретно не получается, выкладывайте конфиги, где конкретно упёрлись, и как диагностировали!
     
  17. Валерий

    Валерий Участник

    # jan/02/1970 01:29:12 by RouterOS 6.15
    # software id = MIIC-6LNL
    #
    /interface wireless
    set [ find default-name=wlan1 ] l2mtu=2290
    /interface ethernet
    set [ find default-name=ether1 ] comment=ISP1
    set [ find default-name=ether2 ] comment=ISP2
    set [ find default-name=ether4 ] master-port=ether3
    set [ find default-name=ether5 ] master-port=ether3
    /ip neighbor discovery
    set ether1 comment=ISP1
    set ether2 comment=ISP2
    /ip hotspot user profile
    set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
    /ip pool
    add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
    /ip dhcp-server
    add address-pool=dhcp_pool1 disabled=no interface=ether3 name=dhcp1
    /ip address
    add address=31.173.225.82/30 interface=ether1 network=31.173.225.80
    add address=192.168.0.1/24 interface=ether3 network=192.168.0.0
    /ip dhcp-client
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether2
    /ip dhcp-server network
    add address=192.168.0.0/24 gateway=192.168.0.1
    /ip dns
    set allow-remote-requests=yes servers=83.149.52.77,83.149.53.77
    /ip firewall address-list
    add address=192.168.0.222 list=list1
    add address=192.168.0.0/24 list=list2
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether1 src-address-list=list1
    add action=masquerade chain=srcnat out-interface=ether2 src-address-list=list2
    add action=netmap chain=dstnat comment="\CF\F0\EE\E1\F0\EE\F1 \CC\C5\C3 \ED\E0 8000" in-interface=ether1 port=8000-8002 protocol=tcp to-addresses=192.168.0.222 to-ports=\
    8000-8002
    add action=netmap chain=dstnat comment="\CF\F0\EE\E1\F0\EE\F1 \D1\CE\CB\CD\D6\C5 8000" in-interface=ether2 port=8000 protocol=tcp to-addresses=192.168.0.222 to-ports=\
    8000-8002
    add action=netmap chain=dstnat comment="\EF\F0\EE\E1\F0\EE\F1 5000 \EC\E5\E3" in-interface=ether1 port=5000 protocol=tcp to-addresses=192.168.0.222 to-ports=5000
    add action=netmap chain=dstnat comment="\EF\F0\EE\E1\F0\EE\F1 5000 \F1\EE\EB\ED\F6\E5" in-interface=ether2 port=5000 protocol=tcp to-addresses=192.168.0.222 to-ports=5000
    /ip route
    add distance=1 gateway=31.173.225.81
    /ip upnp
    set allow-disable-external-interface=no
    /system leds
    set 0 interface=wlan1
     
  18. Валерий

    Валерий Участник

    Вот все, что удалось настроить. Пытался настроить переключение между провайдерами через netwatch, провайдеры переключались несколько раз в итоге отвалились до перезагрузки микротика.
     
  19. Илья Князев

    Илья Князев Администратор Команда форума

    1. В NAT netmap меняем на dst-nat
    2. Где второй шлюз по умолчанию ? Вам достаточно создать 2 разных шлюза по умолчанию с разной дистанцией и включить check-gateway
     
  20. Валерий

    Валерий Участник

    спасибо, попробую. как раз наткнулся на статейку "— Иногда бывают ситуации когда шлюз провайдера работает, а узлы за ним недоступны, Микротик будет считать маршрут рабочим, переключения не произойдет, и интернет работать не будет" такое может произойти при этом способе?