Помогите разобраться

Тема в разделе "Общий форум", создана пользователем hawa, 3 июн 2016.

  1. hawa

    hawa Новый участник

    Всем привет!

    Столкнулся с необходимостью следующей настройки:

    Имеется: 2 роутера Hap AC, подключаемся через PPPOE.

    Как было раньше: порт 1-WAN, настроен PPPOE, порты 2,3,4 - LAN, порт 5 идет на IPTV приставку, которой чтобы работать нужно получить по DHCP провайдера IP (решалось путем выведения порта из бриджа и установкой WAN как мастер порта).

    Как нужно сейчас: порт 1-WAN, настроен PPPOE, порты 2,3,4 - LAN, порт 5 идет на второй роутер. На втором роутере 3 порта под LAN и опять же 1 порт под приставку. Проблему можно было бы решить пробросив дополнительный кабель к приставке, но к сожалению, сделать это невозможно.

    Посоветуйте, как быть! Заранее спасибо!
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    То есть приставку переключаете во второй роутер? Я правильно понял?
     
  3. hawa

    hawa Новый участник

    Да, все верно
     
  4. Илья Князев

    Илья Князев Администратор Команда форума

    Используйте VLAN
     
  5. hawa

    hawa Новый участник

    правильно ли я понимаю, что нужно будет на 5ом порту 1ого роутера создать 2 VLAN, один объеденить с WAN портом, второй с бриджем, а на 2ом роутере через 1ый порт поймать эти 2 VLAN?
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

    В общем да.
     
  7. hawa

    hawa Новый участник

    а есть какие-нибудь особенности в данной настройке?
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

    Я не вижу таковых. Там все просто.
     
  9. hawa

    hawa Новый участник

    Илья, а что этому поводу скажите?

    Но на практике я столкнулся с тем, что приставочный мультикаст почему-то пёр во внутреннюю сеть тоже. Сделал настройки VLANов на свитч-чипе - всё зашуршало как нужно :) Сейчас попробую это описать и переделать на коленке (там был 2011й).
    На 1м роутере на 3-5 порту включаем master-port=ether2, затем:
    /interface ethernet switch port
    set ether2 default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
    set ether3 default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
    set ether4 default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
    set ether5 default-vlan-id=1 vlan-header=add-if-missing vlan-mode=secure

    /interface ethernet switch vlan
    add ports=ether2,ether3,ether4,ether5,switch1-cpu switch=switch1 vlan-id=1
    add ports=ether5,switch1-cpu switch=switch1 vlan-id=2

    /interface vlan
    add comment=local interface=ether2 name=vlan1 vlan-id=1
    add comment=iptv interface=ether2 name=vlan2 vlan-id=2

    /interface bridge
    add comment="LAN bridge" name=bridge1
    add comment="WAN bridge" name=bridge2

    /interface bridge port
    add bridge=bridge1 interface=vlan1
    add bridge=bridge2 interface=vlan2
    add bridge=bridge2 interface=ether1

    На втором роутере на 2-5 портах включаем мастер-порт=езер1, затем:
    /interface vlan
    add interface=ether1 name=vlan1 vlan-id=1
    /interface ethernet switch port
    set ether1 default-vlan-id=1 vlan-header=add-if-missing vlan-mode=secure
    set ether2 default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
    set ether3 default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
    set ether4 default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
    set ether5 default-vlan-id=2 vlan-header=always-strip vlan-mode=secure
    set switch1-cpu default-vlan-id=1 vlan-mode=secure

    Кабель из 5го порта первого роутера в 1й порт второго.
    Приставку, соответственно, в 5й порт второго роутера..
    Если что-то написал неправильно - прошу прощения, т.к. нет железок, чтобы проверить.

    Ах, да. Перевесьте pppoe-клиент на внешний бридж.
     
  10. Илья Князев

    Илья Князев Администратор Команда форума

    Так тоже можно ))) Даже лучше, чем с просто бриджем и VLAN
     
  11. Ddim87

    Ddim87 Новый участник

    Как что то не так так сразу приходиться искать что и где)))
     
  12. Илья Князев

    Илья Князев Администратор Команда форума

    Эмм... Не понял про что, но на всякий случай спасибо )))