Шлюз в другой сети

Тема в разделе "Маршрутизация", создана пользователем Max, 2 авг 2017.

  1. Max

    Max Новый участник

    Моё почтение.

    Есть свой сервер в ДЦ.
    На нём поднят Proxmox и виртуальные машины.
    Для каждой машины свой белый IP.

    Появилось желание спрятать это всё за виртуальным роутером на Router OS и туннелями из филиалов.
    Проблема в том, что инет на нём не поднимается.

    Сам Proxmox имеет ip 37.157.xxx.186
    Шлюз для него 37.157.xxx.254
    Для виртуальных машин ip выделяются из других сетей. Винда на шлюз 37.157.xxx.254 ругается при указании, но потом работает, пакеты бегают.
    Микротик же дальше 37.157.xxx.186 ничего не видит.

    Что я делаю неправильно?
     
  2. AlexShoroh

    AlexShoroh Участник

    Маска подсети какая? Указанные Вами адреса (если ххх одинаковые) упихиваются в подсети /24, /25, /26. В /27 уже не влезают, по этому и ругаться может.
     
  3. Max

    Max Новый участник

    Для виртуальных машин адреса из совсем других сетей.
    Для Микротика, например, 149.202.140.xxx
     
  4. Max

    Max Новый участник

    Уточнение
    Микротик видит все виртуальные машины (217.182.xxx.xxx, 178.33.xxx.xxx, 94.23.xxx.xxx и т.д.) и даже шлюз 37.157.xxx.254
    Трассировка проходит и по имени (днс гугловые)
    А вот дальше никуда.
     
  5. Илья Князев

    Илья Князев Администратор Команда форума

    Схему и конфиг микротика покажите.
     
  6. Max

    Max Новый участник

    Схема
    Proxmox (на нём бридж 0) 37.187.xxx.186/24 и гейт 37.187.xxx.254
    Все виртуальные машины включены в этот бридж.
    У виртуалки с Router OS IP 149.202.xxx.32/32 и гейт 37.187.xxx.254



    # aug/03/2017 09:54:54 by RouterOS 6.39.2
    # software id = 8NCQ-7X0F
    #
    /interface ethernet
    set [ find default-name=ether2 ] name=LAN
    set [ find default-name=ether1 ] name=WAN
    /ip pool
    add name=dhcp ranges=10.0.1.1-10.0.1.200
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=LAN name=dhcp1
    /tool user-manager customer
    set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
    /interface bridge port
    add
    add interface=LAN
    /ip address
    add address=149.202.xxx.32 interface=WAN network=149.202.xxx.32
    add address=10.0.1.254/24 interface=LAN network=10.0.1.0
    /ip dhcp-server network
    add address=10.0.1.0/24 gateway=10.0.1.254 netmask=24
    /ip dns
    set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
    /ip firewall filter
    add action=accept chain=input protocol=icmp
    add action=accept chain=input connection-state=established,related
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=WAN src-address=1.0.1.0/24
    /ip route
    add distance=1 gateway=WAN
    #error exporting /routing pim
    #error exporting /routing rip
    #error exporting /routing ripng
    /system lcd
    set contrast=0 enabled=no port=parallel type=24x4
    /system lcd page
    set time disabled=yes display-time=5s
    set resources disabled=yes display-time=5s
    set uptime disabled=yes display-time=5s
    set packets disabled=yes display-time=5s
    set bits disabled=yes display-time=5s
    set version disabled=yes display-time=5s
    set identity disabled=yes display-time=5s
    set WAN disabled=yes display-time=5s
    set LAN disabled=yes display-time=5s
    /tool user-manager database
    set db-path=user-manager
     
    Последнее редактирование: 3 авг 2017
  7. Илья Князев

    Илья Князев Администратор Команда форума

    Укажите АДРЕС шлюза вместо интерфейса.
     
  8. Max

    Max Новый участник

    Указал
    Не взлетело
     

    Вложения:

    • Mik.png
      Mik.png
      Размер файла:
      6,1 КБ
      Просмотров:
      5
  9. Илья Князев

    Илья Князев Администратор Команда форума

    У вас шлюз 149 что-то там.
     
  10. Max

    Max Новый участник

    Сам для себя шлюз?
    IP микротика с маской 32
     
  11. Илья Князев

    Илья Князев Администратор Команда форума

    Хм. А обратый маршрут на вас есть у провайдера?
     
  12. Max

    Max Новый участник

    Должен быть.
    Остальные виртуалки по аналогии работают без проблем.
    Заказываешь дополнительный ip, в админке привязываешь к нему mac. В Proxmox в настройках сетевого интерфейса указываешь этот mac.
    В самой виртуалке указываешь статикой ip с маской 32, шлюз для Proxmox и гугловые ДНС и всё работает
     
  13. Max

    Max Новый участник

    Заработало )))


    Thank you everyone for help, that was a problem with IP on OVH router, i got new one and its works [​IMG]
    Very important is correctly assigne IP to mac address on OVH portal
    IP address with end .254 is RouterOS gateway

    This is working configuration:

    Details about IP and mac address from hosting provider:
    Code: Select all
    IPv4 configuration
    MAC:00:50:56:09:c8:e2
    IPv4:191.91.41.141
    Netmask:255.255.255.255
    Gateway:198.28.78.254

    Detail about commend to use on RouterOS:
    Code: Select all
    /interface ethernet set WAN mac-address=00:50:56:09:c8:e2
    /ip address add address=191.91.41.141/32interface=ether1 network=198.28.78.254
    /ip route add gateway=198.28.78.254

    Details from configuration:
    Code: Select all
    [admin@MikroTik]> ip address print detail
    Flags: X - disabled, I - invalid, D -dynamic
    0 address=191.91.41.141/32 network=198.28.78.254interface=ether1 actual-interface=ether1

    Code: Select all
    [admin@MikroTik]> ip route print detail
    Flags: X - disabled, A - active, D -dynamic, C - connect, S -static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    0 A S dst-address=0.0.0.0/0 gateway=198.28.78.254 gateway-status=198.28.78.254 reachable via ether1 distance=1
    scope=30 target-scope=10
    1 ADC dst-address=198.28.78.254/32 pref-src=191.91.41.141 gateway=ether1 gateway-status=ether1 reachable distance=0
    scope=10

    Code: Select all
    [admin@MikroTik]> ping 8.8.8.8
    HOST SIZE TTL TIME STATUS
    8.8.8.8564523ms
    8.8.8.8564523ms
    8.8.8.8564523ms
    sent=3 received=3 packet-loss=0% min-rtt=23ms avg-rtt=23ms max-rtt=23ms