Виснет 3g модем на Mikrotik RB951

Тема в разделе "Вопросы начинающих", создана пользователем Hyper_Soii, 16 сен 2016.

  1. Hyper_Soii

    Hyper_Soii Новый участник

    Друзья, есть загородный дом с большой нагрузкой на интернет канал. Около 6 активных пользователей, постоянный трафик в виде ютуб и фильмов онлайн. Модем хуавей е3372 подключен к роутеру через удлинитель 1 метр. Проблема в том, что порт модема постоянно падает. Особенно, когда активно ходит трафик. Скорость йоты с внешней антенной около 6-10 мегабит. Поэтому по сути модем всегда работает на полной мощности. Пробовал сварганить свой активный юсб инжектор с реле, все работает, но модем не видится. Купил заводской активный юзб хаб с блоком питания 2А. Тоже не видится через него. Сейчас решил заказать у Вас микротиковский юсб инжектор, за 200 руб. На случай если не правильно спаял. Пробовал менять прошивки. Ничего не помогает. Менял блок питания, дохлый номер, взял какой то с ноута 12В 7А.

    [admin@MikroTik] > export compact
    # sep/15/2016 22:51:37 by RouterOS 6.36.3
    # software id = 49IN-YKP4
    #
    /interface lte
    set [ find ] mac-address=0C:5B:8F:27:9A:64 name=lte1
    /interface bridge
    add admin-mac=E4:8D:8C:D5:D4:75 auto-mac=no comment=defconf name=bridge
    /interface ethernet
    set [ find default-name=ether2 ] name=ether2-master
    set [ find default-name=ether3 ] master-port=ether2-master
    set [ find default-name=ether4 ] master-port=ether2-master
    set [ find default-name=ether5 ] master-port=ether2-master
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=\
    ap-bridge ssid=Hyper_Soii wireless-protocol=802.11
    /ip neighbor discovery
    set ether1 discover=no
    set bridge comment=defconf
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys wpa2-pre-shared-key=megap0int
    /ip pool
    add name=default-dhcp ranges=192.168.88.10-192.168.88.254
    /ip dhcp-server
    add address-pool=default-dhcp disabled=no interface=bridge name=defconf
    /interface bridge port
    add bridge=bridge comment=defconf interface=ether2-master
    add bridge=bridge comment=defconf interface=wlan1
    /ip address
    add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0
    /ip dhcp-client
    add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=lte1
    /ip dhcp-server network
    add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
    /ip dns
    set allow-remote-requests=yes
    /ip dns static
    add address=192.168.88.1 name=router
    /ip firewall filter
    add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
    add action=accept chain=input comment="defconf: accept established,related" connection-state=established,related
    add action=drop chain=input comment="defconf: drop all from WAN" in-interface=ether1
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
    add action=accept chain=forward comment="defconf: accept established,related" connection-state=established,related
    add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
    add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new \
    in-interface=ether1
    add action=drop chain=input comment="Filter for LTE1" in-interface=lte1
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=ether1
    add action=masquerade chain=srcnat comment="NAT for LTE1" out-interface=lte1
    /system clock
    set time-zone-name=Europe/Moscow
    /system leds
    set 5 interface=wlan1
    /system routerboard settings
    # Firmware upgraded successfully, please reboot for changes to take effect!
    set init-delay=0s protected-routerboot=disabled
    /system script
    add name=reboot_yota owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/system routerboard usb power-reset duration=3"
    /tool mac-server
    set [ find default=yes ] disabled=yes
    add interface=bridge
    /tool mac-server mac-winbox
    set [ find default=yes ] disabled=yes
    add interface=bridge
    /tool netwatch
    add down-script=reboot_yota host=192.168.8.1 interval=30s

    Что еще можно сделать?
    Сегодня начал ковырять phsense дистриб роутера на линаксе. Однако перспектива постоянно включенного домашнего сервака не блещет! Расход энергии важен.
    Есть мысль бросить все к чертям и купить зуксель кинетик, у которого наверняка таких проблем с зависанием нет.
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Если смотреть вашу конфигурацию, то у вас есть скрипт с перезагрузкой модема, но нет того, кто его вызывает.
    Добавьте в конфиг
    Код:
    /tool netwatch
    add down-script="/system routerboard usb power-reset duration=5" host=8.8.8.8
    
    Хост можете подправить на тот, который проверять будете. Проверьте что он работает.

    Если не поможет разбирайтесь с железом.
    Вариант раз http://spw.ru/equipment/routerswifi/sxt_lte/ и к нему WiFi-роутер
    Вариант 2.
    Запитать модем через PoE-ижектор
    http://spw.ru/equipment/components/5vusb/ но к нему надо еще 5 вольт блок питания прикупить
    Вариант 3
    Заменить 951Ui на hAP Lite AC http://spw.ru/equipment/routerswifi/hap_lite_ac/
    У нее 1А на USB-порту.
     
    Mama нравится это.
  3. Hyper_Soii

    Hyper_Soii Новый участник

    Если смотреть вашу конфигурацию, то у вас есть скрипт с перезагрузкой модема, но нет того, кто его вызывает.
    Добавьте в конфиг
    Код:
    /tool netwatch
    add down-script="/system routerboard usb power-reset duration=5" host=8.8.8.8
    
    Хост можете подправить на тот, который проверять будете. Проверьте что он работает.

    Илья, тут все работает.
    мне достаточно пинговать не гугл а веб морду модема, он в режиме хайлинк.

    Код:
    /tool netwatch
    add down-script=reboot_yota host=192.168.8.1 interval=30s
    Очень крутая железка, но дорогая!
    По ценообразования, сейчас так:
    роутер микротик 3 тыс.
    антенна антекс 2,5 тыс
    модем е3372 2 тыс.
    итого на 7 тыс.
    А тут сразу на 10!
    Плюс еще отдельно вайфай точку в дом.
    Вот если бы б.у. где нибудь найти с большой скидкой тогда супер.

    Подскажите пожалуйста
    SXT LTE имеет возможность как и любой роутер править на ван порте параметр TTL? это нужно для дешевого тарифа йота и других.


    пробовал, почему то модем в данном режиме невидится. Сейчас жду заводской инжектор микротик.
    Вариант 3
    Заменить 951Ui на hAP Lite AC http://spw.ru/equipment/routerswifi/hap_lite_ac/
    У нее 1А на USB-порту.
    Это возможно выход. Скажите пожалуйста можно у Вас взять на тест драйв этот роутер, попробую погонять 3 дня?

    вчера попробовал выключить на микротике модуль фай вай... и отправил трафик на роутер длинк где настроена точка. Причем последнему запретил нат, т.е. тупо как свитч в режиме точки. По факту пинг с 40 мс, вырос до 250... кроме того ночью модем ночью как и раньше завис и ребутнулся...

    Также наблюдаю, что с блоком питания 7А, зависания стали большой редкостью... возможно оставлю данную схему.
    Есть мысли пробросить радио мост, точка точка от ближайшего высотного дома другого поселка. Расстояние примерно 3 км. Думаю на убикути можно собрать такой канал. Главное найти бабушку, которая разрешить повесить на окно тарелку.[/QUOTE]
     
    Последнее редактирование: 19 сен 2016
  4. Илья Князев

    Илья Князев Администратор Команда форума

    Да, там же обычная RouterOS
    Обратитесь к нашим продажникам. Думаю можно.
     
  5. Hyper_Soii

    Hyper_Soii Новый участник

    Скажите пожалуйста в hAP Lite AC поддерживается команда: "/system routerboard usb power-reset duration=3" ?
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

  7. Hyper_Soii

    Hyper_Soii Новый участник

    Поставил инжектор USB на 951Ui. Родной микротиковский. В итоге модем не видится. До этого сам спаял с релюшкой, тоже самое было.
     
  8. Hyper_Soii

    Hyper_Soii Новый участник

    Посоветовали связку rb912 + mc7710
    ок! читаю отзывы, народ пишет, что как и свисток связь отваливается 5-8 раз в день. В итоге думаю, нужно строить вай фай мост и не парится с этими модемами.
     
  9. Илья Князев

    Илья Князев Администратор Команда форума

    Да, это обычно лучшее решение )
     
  10. Hyper_Soii

    Hyper_Soii Новый участник

    Приходили монтажники провайдера. Отказались делать радио мост... сказали прямой видимости нет. Похоже быть мне на 3гэ инете. Решил пока попробовать купить модель hAP Lite AC с манибэком.
     
  11. Илья Князев

    Илья Князев Администратор Команда форума

    Сообщите потом о результатах. Мне интересно
     
  12. Hyper_Soii

    Hyper_Soii Новый участник

    Илья, прошла неделя на роутере hAP Lite AC. Разница просто небо и земля.
    Всю неделю внимательно смотрел на логи.
    • Ни одного зависания роутера на прошивке 6.37.1
    • Ни одного ап и даун юзб интерфейса ЛТЕ. Отключил скрипт автоматического сброса юзб порта.
    • Скорость выросла значительно.
    В среднем сессия ЛТЕ в админке модема держится около 50 часов. Потом она сбрасывается. При этом сам модем не зависает и никаких остановок с трафике не наблюдается. Напомню модем Хуавей 3372. Один из самых популярных. Прошит в режиме HiLink, т.е. имеем двойной NAT. Камрады пишут, что по факту скорость не меняется если переключить модем в режим ком порта. Поэтому Не стал заморачиватся. А так если решится, то много плюшек появляется. Например микротик может анализировать входящие смс. Можно отправить ему любую команду с мобильного. Перезагрузится например, если отвалился интернет 3G.

    Также перешел на оператора МТС с Йоты, опять же разница огромная. Уровень сигнала немного ниже... Но по факту скорость выше. Было 4-18 мегабит и пинг 80-400 мс. Стало 10-30 с пингом 30-70. Причем нижний порог как правило не ниже 17 мегабит.
     
    Илья Князев нравится это.
  13. Илья Князев

    Илья Князев Администратор Команда форума

    Вот и отлично. Будем и другим советовать.