VLAN через беспроводной мост

Тема в разделе "Коммутация", создана пользователем darkrock87, 31 мар 2020.

  1. darkrock87

    darkrock87 Новый участник

    Дорого времени суток.

    Пытался настроить VLAN через беспроводной мост. Схема состоит из 3 устройств… RT-1 (основной роутер) к нему подключен в 6 порт WAP1 (беспроводная точка SXTG-5HPacD). А эта точка подключена по беспроводному каналу к WAP2 (беспроводная точка SXTG-5HPacD). WAP1 и WAP2 должны получать IP по DHCP с интерфейса «bridge-Network» через vlan-id=199.
    В итоге WAP1 получает IP адрес, а WAP2 не получает адрес. Беспроводное соединение есть.
    Сразу поясню зачем тут два VLANа, один для сетевого оборудования, другой для пользователей….
    Ниже конфиг… Что не так? Подскажите пожалуйста.


    ----------------- RT-1 ---------------------
    # model = CCR1009-7G-1C-1S+
    /interfacebridge
    addarp=proxy-arpname=bridge-Network
    add arp=proxy-arp name=bridge-TempLAN

    /interface vlan
    add interface=ether6 name=vlan-ether6-Network-199 vlan-id=199
    add interface=ether6 name=vlan-ether6-TempLAN-223 vlan-id=223

    /ip pool
    add name=pool-DHCP-bridge-Network ranges=10.12.254.1-10.12.254.253
    add name=pool-DHCP-bridge-TempLAN ranges=10.0.0.2-10.0.0.253

    /ip dhcp-server
    add add-arp=yes address-pool=pool-DHCP-bridge-Network always-broadcast=yes \
    disabled=no interface=bridge-Network lease-time=1d10m name=\
    DHCP-bridge-Network
    add add-arp=yes address-pool=pool-DHCP-bridge-TempLAN always-broadcast=yes \
    disabled=no interface=bridge-TempLAN name=DHCP-bridge-bridge-TempLAN

    /interface bridge port
    add bridge=bridge-Network interface=vlan-ether6-Network-199 trusted=yes
    add bridge=bridge-TempLAN interface=vlan-ether6-TempLAN-223 trusted=yes

    /ip address
    add address=10.12.254.254/24 interface=bridge-Network network=10.12.254.0
    add address=10.0.0.1/24 interface=bridge-TempLAN network=10.0.0.0

    /ip dhcp-server network
    add address=10.0.0.0/24 dns-server=10.0.0.1 gateway=10.0.0.1 netmask=24
    add address=10.12.254.0/24 dns-server=10.12.254.254 gateway=10.12.254.254 \
    netmask=24 ntp-server=10.12.254.254

    /ip dns
    set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

    --------------------------------------



    ------------------ WAP1 ---------------------
    # model = SXT G-5HPacD
    /interface bridge
    add arp=proxy-arp name=bridge-Network
    add arp=proxy-arp name=bridge-TempLAN

    /interface wireless
    set [ find default-name=wlan1 ] arp=proxy-arp band=5ghz-n/ac channel-width=\
    20/40/80mhz-Ceee country="united states3" disabled=no frequency=auto \
    installation=outdoor mode=ap-bridge multicast-helper=full \
    nv2-preshared-key="************************" nv2-qos=\
    frame-priority nv2-security=enabled ssid=xxxxxxxxxx tdma-period-size=1 \
    wireless-protocol=nv2

    /interface ethernet
    set [ find default-name=ether1 ] arp=proxy-arp

    /interface vlan
    add interface=ether1 name=vlan-ether1-Network-199 vlan-id=199
    add interface=ether1 name=vlan-ether1-TempLAN-223 vlan-id=223
    add interface=wlan1 name=vlan-wlan1-Network-199 vlan-id=199
    add interface=wlan1 name=vlan-wlan1-TempLAN-223 vlan-id=223

    /interface bridge port
    add bridge=bridge-Network interface=vlan-ether1-Network-199 trusted=yes
    add bridge=bridge-TempLAN interface=vlan-ether1-TempLAN-223 trusted=yes

    /ip dhcp-client
    add disabled=no interface=bridge-Network
    --------------------------


    ------------------ WAP2 ---------------------
    # model = SXT G-5HPacD r2
    /interface bridge
    add arp=proxy-arp name=bridge-Network
    add arp=proxy-arp name=bridge-TempLAN

    /interface wireless
    set [ find default-name=wlan1 ] arp=proxy-arp band=5ghz-n/ac channel-width=\
    20/40/80mhz-Ceee disabled=no mode=station-bridge multicast-helper=full \
    nv2-preshared-key="*****************************" nv2-security=enabled \
    ssid=xxxxxxxxxx wireless-protocol=nv2

    /interface vlan
    add interface=ether1 name=vlan-ether1-TempLAN-223 vlan-id=223
    add interface=wlan1 name=vlan-wlan1-Network-199 vlan-id=199
    add interface=wlan1 name=vlan-wlan1-TempLAN-223 vlan-id=233

    /interface bridge port
    add bridge=bridge-TempLAN interface=vlan-wlan1-TempLAN-223 trusted=yes
    add bridge=bridge-TempLAN interface=vlan-ether1-TempLAN-223 trusted=yes
    add bridge=bridge-Network interface=vlan-wlan1-Network-199 trusted=yes

    /ip dhcp-client
    add disabled=no interface=bridge-Network
    --------------------------
     
  2. darkrock87

    darkrock87 Новый участник

    Вопрос решён, моя тупость забыл в портах бриджа добавить vlan-wlan1-Network-199 и vlan-wlan1-TempLAN-223 на WAP1
     
  3. MaxMelLlit

    MaxMelLlit Новый участник