Вопросы по настройке роутера с нуля

Тема в разделе "Вопросы начинающих", создана пользователем Mama, 15 май 2016.

  1. Mama

    Mama Участник

    Друзья, добрый день!

    Подскажите пожалуйста:
    1 - в чем принципиальная разница между настройкой роутера по стартовому скрипту, настройкой в ручную и через Quick set?
    2 - настраиваю роутер по этой инструкции, в финале имеется проблема "не удалось обнаружить параметры прокси этой сети". Вспоминаю про ip->routes. Копирую записи с рабочего конфига. Опять проблема не недоступностью сетей. На скрине слева конфиг на старотовом скрипте, справа собраный руками
    Что я не так делаю?
    Заранее спасибо

    Снимок11111111111111111.JPG
     
  2. Dmitry_S

    Dmitry_S Участник

    ИМХО, вы указали внешний IP-адрес вручную, а раньше его получали от DHCP. Или неправильно указали значения в IP/Addresses
     
    Mama нравится это.
  3. Илья Князев

    Илья Князев Администратор Команда форума

    Или не на тот интерфейс адрес повесили...
     
    Mama нравится это.
  4. Mama

    Mama Участник

    а по первому вопросу возможно что то прокомментировать? Какие есть недостатки у дефолтной конфигурации?

    Заранее спасибо
     
  5. Илья Князев

    Илья Князев Администратор Команда форума

    Никаких существенных недостатков нету. Можете использовать ее.
     
    Mama нравится это.
  6. Mama

    Mama Участник

    Ок. Что бы не плодить темы поинтересуюсь здесь:
    поднимаю рртр - трафик есть инструкция
    поднимаю eoip, соединяю с бриджем, теряю линк с инетом. пробовал менять стоимость и приоретизацию, не помогло. Что покрутить?
     
    Последнее редактирование: 15 май 2016
  7. Илья Князев

    Илья Князев Администратор Команда форума

    Понятия не имею. Дайте конфиг.
    команда /export.
     
  8. Mama

    Mama Участник

    # may/15/2016 20:46:37 by RouterOS 6.35.2
    # software id =
    #
    /interface bridge
    add admin-mac=E4:8D:8C:CF:5D:AF auto-mac=no comment=defconf name=bridge
    /interface ethernet
    set [ find default-name=ether1 ] mac-address=4C:72:B9:54:EC:--
    set [ find default-name=ether2 ] name=ether2-master
    set [ find default-name=ether3 ] master-port=ether2-master
    set [ find default-name=ether4 ] master-port=ether2-master
    set [ find default-name=ether5 ] master-port=ether2-master
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country=russia \
    disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=Batman_cave \
    wireless-protocol=802.11
    /interface pptp-client
    add allow=mschap1,mschap2 connect-to=89.223.63.-- disabled=no mrru=1600 name=pptp-out1 \
    password=-- user=--
    /interface eoip
    add !keepalive mac-address=02:14:E9:B8:F1:28 name=eoip-tunnel1 remote-address=89.223.63.-- \
    tunnel-id=0
    /ip neighbor discovery
    set ether1 discover=no
    set bridge comment=defconf
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys \
    supplicant-identity=MikroTik wpa-pre-shared-key=-- wpa2-pre-shared-key=\
    --
    /ip hotspot profile
    set [ find default=yes ] html-directory=flash/hotspot
    /ip pool
    add name=dhcp ranges=192.168.1.100-192.168.1.150
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=bridge name=defconf
    /interface bridge port
    add bridge=bridge comment=defconf interface=ether2-master
    add bridge=bridge comment=defconf interface=wlan1
    add bridge=bridge interface=eoip-tunnel1
    /ip address
    add address=192.168.1.2/24 comment=defconf interface=ether2-master network=192.168.1.0
    add address=89.223.40.43/28 interface=ether1 network=89.223.40.32
    /ip dhcp-client
    add comment=defconf dhcp-options=hostname,clientid interface=ether1
    /ip dhcp-server network
    add address=192.168.1.0/24 comment=defconf gateway=192.168.1.2 netmask=24
    /ip dns
    set allow-remote-requests=yes servers=89.223.47.133,89.223.47.132
    /ip dns static
    add address=192.168.1.2 name=router
    /ip firewall filter
    add chain=input comment="defconf: accept ICMP" protocol=icmp
    add chain=input comment="defconf: accept established,related" connection-state=\
    established,related
    add chain=input comment="defconf: accept IGMP" protocol=igmp
    add action=drop chain=input comment="defconf: drop all from WAN" in-interface=ether1
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
    add chain=forward comment="defconf: accept established,related" connection-state=\
    established,related
    add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
    add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
    add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new disabled=yes in-interface=ether1
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=ether1
    /ip route
    add distance=1 gateway=89.223.40.33
    /ip upnp
    set enabled=yes
    /ip upnp interfaces
    add interface=bridge type=internal
    add interface=ether1 type=external
    /routing igmp-proxy
    set quick-leave=yes
    /routing igmp-proxy interface
    add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
    add interface=bridge
    /system clock
    set time-zone-name=Europe/Volgograd
    /system identity
    set name=WhiteRabbit
    /system leds
    set 5 interface=wlan1
    /system ntp client
    set enabled=yes primary-ntp=128.138.141.172
    /system routerboard settings
    set cpu-frequency=650MHz init-delay=0s protected-routerboot=disabled
    /tool mac-server
    set [ find default=yes ] disabled=yes
    add interface=bridge
    /tool mac-server mac-winbox
    set [ find default=yes ] disabled=yes
    add interface=bridge


    up

    раньше настраивал eoip согласно этой инструкции.
    Сеть А и сеть В - 192.168.1.1/24
    Для рртр локальный адрес 192.168.2.1, удаленный 192.168.2.2
    Для eoip локальный адрес 192.168.3.1, удаленный 192.168.3.2

    Теперь для eoip указал внешний адрес роутера В.
    Прописал адреса 192.168.1.1/24 на интерфейс eoip
    Трафик в ту сторону пошел, но хосты на той стороне не пингуются. Внешний ip рутера В на пинг отвечает. Доступ в инет есть.
    Что еще попинать? :rolleyes:
     
    Последнее редактирование: 15 май 2016
  9. Илья Князев

    Илья Князев Администратор Команда форума

    Вы если создали бридж, то адрес роутера надо на него повесить
     
  10. Mama

    Mama Участник

    Друзья, всем дня!
    Пожевав еще и еще матчасть, я таки запустил eoip и даже добился искомого: с одного ip вижу dlna в подсети на другом. И все бы не плохо, но... На той стороне жалуются на "медленноватый интернет", на своей стороне жалуюсь на недоступность некоторых сайтов, так же снижение скорости и странности на некоторых сайтах

    https://web.skype.com/ru/
    [​IMG]
    И этот вообще загрузился

    Роутер Б подключен к А клиентом по pptp. Статичные белые ip.

    a.txt

    b.txt

    Что я делаю не так?

    Заранее спасибо
     

    Вложения:

    • OaaW56CzQkY.jpg
      OaaW56CzQkY.jpg
      Размер файла:
      69,9 КБ
      Просмотров:
      4
    • a.txt
      Размер файла:
      5,1 КБ
      Просмотров:
      9
    • b.txt
      Размер файла:
      5,4 КБ
      Просмотров:
      2
  11. Илья Князев

    Илья Князев Администратор Команда форума

    2 dhcp сервера и eoip в бридже...
    Я так понимаю что теперь у вас клиенты в одном офисе получают шлюз в другом.
     
  12. Mama

    Mama Участник

    Я правильно понимаю, что прибить на файерволе порты 67, 68 будет не самое изысканное решение? Наверняка же есть более красивый вариант? =)
     
    Последнее редактирование: 6 июн 2016
  13. Илья Князев

    Илья Князев Администратор Команда форума

    А другого собственно и нет.
    Используйте /bridge filter
    Ну и до кучи. Вам не обязательно поднимать eoip в pptp. Используйте BCP вместо EoIP.
     
  14. Mama

    Mama Участник

    Друзья, все дня!

    Подскажите пожалуйста:
    поднял sstp с bcp, но потерял iptv. Куда еще руки приложить?

    Заранее спасибо
     

    Вложения:

    • sstp_client.txt
      Размер файла:
      2,9 КБ
      Просмотров:
      4
    • sstp_srv.txt
      Размер файла:
      3,6 КБ
      Просмотров:
      3
  15. Илья Князев

    Илья Князев Администратор Команда форума

    Вы бы схему в итоге нарисовали со всеми сервисами. Честное слово нету времени копать каждый конфиг по одному вопросу.
    IPTV по какому протоколу идет? Если Multecast то приложить к соотвествующему пакету.
     
  16. Mama

    Mama Участник

    Вам не сложно чуть поподробнее рассказать? Пакеты то стоят. Iptv до подключения клиентского интерфейса sstp есть, подключаю - нет
     
  17. Илья Князев

    Илья Князев Администратор Команда форума

    Вам нужно или отдать внутрь второй сети Ethernet, или настроить Multicast
     
  18. Ростислав

    Ростислав Новый участник

    Добрый день, приобрёл RB951G-2HnD и не могу настроить интернет.
    Провайдер убрал привязку по Маку, чтобы исключить другие проблемы.
    Я зашёл в настройки, прописал quick set (static IP) ip адрес, маску, шлюз, DNS1 и DNS2
    WAN кабель воткнул в разъём 1, но интернета нет. Даже не пингуется шлюз провайдера. На другом роутере все работает.
    Даже прошивку решил обновить на всякий случай.
    Подскажите пожалуйста, в чём может быть проблема
    В прикреплении настройки, которые прописались после quick set
    Итак, с проблемой разобрался. Причина - фаерволл (в роутере). После его отключения, интернет появился.
    Сейчас разбираюсь, как его настроить правильно.
     

    Вложения:

    • addresses.jpg
      addresses.jpg
      Размер файла:
      84,3 КБ
      Просмотров:
      2
    • dns.jpg
      dns.jpg
      Размер файла:
      146,9 КБ
      Просмотров:
      2
    • firewall.jpg
      firewall.jpg
      Размер файла:
      329 КБ
      Просмотров:
      1
    • interfaces.jpg
      interfaces.jpg
      Размер файла:
      272,4 КБ
      Просмотров:
      1
    • quickset.jpg
      quickset.jpg
      Размер файла:
      201,3 КБ
      Просмотров:
      1
    • routes.jpg
      routes.jpg
      Размер файла:
      170,6 КБ
      Просмотров:
      1
    Последнее редактирование: 21 июл 2016
  19. Илья Князев

    Илья Князев Администратор Команда форума

    Интерфейс поднимается?
    Дайте экспорт конфига команда
    /export
     
  20. Ростислав

    Ростислав Новый участник

    всё работает, только фаерволл не пускает в инет
    Код:
    # jul/21/2016 13:57:46 by RouterOS 6.35.4
    
    # software id = V1I3-20ZY
    #
    /interface bridge
    add admin-mac=6C:3B:6B:00:80:E3 auto-mac=no comment=defconf name=bridge
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
        disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=\
        MikroTik-0080E7 wireless-protocol=802.11
    /interface ethernet
    set [ find default-name=ether1 ] mac-address=78:54:2E:E1:8A:CA
    set [ find default-name=ether2 ] name=ether2-master
    set [ find default-name=ether3 ] master-port=ether2-master
    set [ find default-name=ether4 ] master-port=ether2-master
    set [ find default-name=ether5 ] master-port=ether2-master
    /ip neighbor discovery
    set bridge comment=defconf
    /ip pool
    add name=dhcp ranges=192.168.88.10-192.168.88.254
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=bridge name=defconf
    /interface bridge port
    add bridge=bridge comment=defconf interface=ether2-master
    add bridge=bridge comment=defconf interface=wlan1
    /ip address
    add address=192.168.88.1/24 comment=defconf interface=ether2-master network=\
        192.168.88.0
    add address=10.200.188.116/22 interface=ether1 network=10.200.188.0
    /ip dhcp-client
    add comment=defconf dhcp-options=hostname,clientid interface=ether1
    /ip dhcp-server network
    add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
    /ip dns
    set allow-remote-requests=yes servers=192.168.248.21,192.168.251.21
    /ip dns static
    add address=192.168.88.1 name=router
    /ip firewall filter
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
        connection-state=established,related
    add chain=forward comment="defconf: accept established,related" \
        connection-state=established,related
    add action=drop chain=forward comment="defconf: drop invalid" \
        connection-state=invalid
    add action=drop chain=forward comment=\
        "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
        connection-state=new in-interface=ether1
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" \
        out-interface=ether1
    /ip route
    add distance=1 gateway=10.200.188.1
    /system clock
    set time-zone-name=Europe/Moscow
    /system leds
    set 0 interface=wlan1
    /system routerboard settings
    set init-delay=0s protected-routerboot=disabled