VRF

Тема в разделе "Общий форум", создана пользователем unixlamaster, 7 июн 2016.

  1. unixlamaster

    unixlamaster Новый участник

    Добрый день!
    Собираю схему в которой пытаюсь разнести на разные VRF ядро сети (OSPF+BGP+VPLS) и Интернет (192.168.6.0/30 + 192.168.7.0/24)
    Без VRF все работает, в Инет выхожу через VPLS.
    Включаю VRF, перестаёт работать VPLS.
     
  2. unixlamaster

    unixlamaster Новый участник

    Прикрепляю файл с логами и конфигами
     

    Вложения:

  3. Илья Князев

    Илья Князев Администратор Команда форума

    Посмотрите torch, скорее всего перестает ходить LDP. Тогда надо в Mangle его туда "запихнуть"
     
  4. unixlamaster

    unixlamaster Новый участник

    Подскажите пожалуйста как правильно настраивать BGP+VRF?
    Собираю схему в GNS3, картинку прикрепил.
    Конфиги:

    RouterOS-1


    # jul/13/2016 06:34:13 by RouterOS 6.35.4
    # software id =
    #
    /interface bridge
    add name=loop1 protocol-mode=none
    /interface ethernet
    set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-full \
    auto-negotiation=no speed=1Gbps
    set [ find default-name=ether2 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-full \
    auto-negotiation=no speed=1Gbps
    set [ find default-name=ether3 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-full \
    speed=1Gbps
    /routing bgp instance
    set default router-id=10.100.0.1 routing-table=core_vrf
    /routing ospf instance
    set [ find default=yes ] name=core router-id=10.100.0.1 routing-table=core_vrf
    /ip address
    add address=192.168.88.1/24 interface=ether3 network=192.168.88.0
    add address=10.10.0.1/30 interface=ether1 network=10.10.0.0
    add address=10.100.0.1 interface=loop1 network=10.100.0.1
    add address=10.10.0.5/30 interface=ether2 network=10.10.0.4
    /ip dhcp-client
    add disabled=no interface=ether1
    /ip route vrf
    add interfaces=ether1,ether2,loop1 routing-mark=core_vrf
    /routing bgp peer
    add address-families=l2vpn name=peer1 remote-address=10.100.0.2 remote-as=65530 \
    route-reflect=yes ttl=default update-source=loop1
    add address-families=l2vpn name=peer2 remote-address=10.100.0.3 remote-as=65530 \
    route-reflect=yes ttl=default update-source=loop1
    /routing ospf interface
    add dead-interval=4s hello-interval=1s interface=ether1 network-type=nbma \
    retransmit-interval=1s
    add dead-interval=4s hello-interval=1s interface=ether2 network-type=nbma \
    retransmit-interval=1s
    /routing ospf nbma-neighbor
    add address=10.10.0.2
    add address=10.10.0.6
    /routing ospf network
    add area=backbone network=10.100.0.1/32
    add area=backbone network=10.10.0.0/30
    add area=backbone network=10.10.0.4/30
    /system logging
    add topics=bgp,debug
    [admin@MikroTik] >



    RouterOS Clone1-1

    # jul/13/2016 06:35:35 by RouterOS 6.35.4
    # software id =
    #
    /interface bridge
    add name=loop1 protocol-mode=none
    /interface ethernet
    set [ find default-name=ether1 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-full auto-negotiation=no speed=1Gbps
    /routing bgp instance
    set default client-to-client-reflection=no router-id=10.100.0.2 routing-table=core_vrf
    /routing ospf instance
    set [ find default=yes ] name=core router-id=10.100.0.2 routing-table=core_vrf
    /ip address
    add address=192.168.88.2/24 interface=ether3 network=192.168.88.0
    add address=10.10.0.2/30 interface=ether1 network=10.10.0.0
    add address=10.100.0.2 interface=loop1 network=10.100.0.2
    /ip dhcp-client
    add disabled=no interface=ether1
    /ip route vrf
    add interfaces=ether1,loop1 routing-mark=core_vrf
    /routing bgp peer
    add address-families=l2vpn name=peer1 remote-address=10.100.0.1 remote-as=65530 ttl=\
    default update-source=loop1
    /routing ospf interface
    add dead-interval=4s hello-interval=1s interface=ether1 network-type=nbma \
    retransmit-interval=1s
    /routing ospf nbma-neighbor
    add address=10.10.0.1
    /routing ospf network
    add area=backbone network=10.100.0.2/32
    add area=backbone network=10.10.0.0/30
    /system logging
    add topics=bgp

    > log print
    06:36:00 route,bgp,debug Connecting
    06:36:00 route,bgp,debug RemoteAddress=10.100.0.1
    06:36:00 route,bgp,debug,state Entering Connect state
    06:36:00 route,bgp,debug,state RemoteAddress=10.100.0.1
    06:36:19 route,bgp,debug,timer ConnectRetryTimer expired
    06:36:19 route,bgp,debug,timer RemoteAddress=10.100.0.1
    06:36:19 route,bgp,debug Update source
    06:36:19 route,bgp,debug Address=10.100.0.2
    06:36:19 route,bgp,debug Connecting
    06:36:19 route,bgp,debug RemoteAddress=10.100.0.1
    06:36:19 route,bgp,debug,state Entering Connect state
    06:36:19 route,bgp,debug,state RemoteAddress=10.100.0.1
    06:36:37 route,bgp,debug,timer ConnectRetryTimer expired
    06:36:37 route,bgp,debug,timer RemoteAddress=10.100.0.1
    06:36:37 route,bgp,debug Update source
    06:36:37 route,bgp,debug Address=10.100.0.2
    06:36:37 route,bgp,debug Connecting
    06:36:37 route,bgp,debug RemoteAddress=10.100.0.1
    06:36:37 route,bgp,debug,state Entering Connect state
    06:36:37 route,bgp,debug,state RemoteAddress=10.100.0.1
    06:36:55 route,bgp,debug,timer ConnectRetryTimer expired
    06:36:55 route,bgp,debug,timer RemoteAddress=10.100.0.1
    06:36:55 route,bgp,debug Update source
    06:36:55 route,bgp,debug Address=10.100.0.2
    06:36:55 route,bgp,debug Connecting
    06:36:55 route,bgp,debug RemoteAddress=10.100.0.1
    06:36:55 route,bgp,debug,state Entering Connect state
    06:36:55 route,bgp,debug,state RemoteAddress=10.100.0.1
    06:37:14 route,bgp,debug,timer ConnectRetryTimer expired
    06:37:14 route,bgp,debug,timer RemoteAddress=10.100.0.1
    06:37:14 route,bgp,debug Update source
    06:37:14 route,bgp,debug Address=10.100.0.2
    06:37:14 route,bgp,debug Connecting
    06:37:14 route,bgp,debug RemoteAddress=10.100.0.1
    06:37:14 route,bgp,debug,state Entering Connect state
    06:37:14 route,bgp,debug,state RemoteAddress=10.100.0.1
    06:37:33 route,bgp,debug,timer ConnectRetryTimer expired
    06:37:33 route,bgp,debug,timer RemoteAddress=10.100.0.1
    06:37:33 route,bgp,debug Update source
    06:37:33 route,bgp,debug Address=10.100.0.2
    06:37:33 route,bgp,debug Connecting
    06:37:33 route,bgp,debug RemoteAddress=10.100.0.1
    06:37:33 route,bgp,debug,state Entering Connect state
    06:37:33 route,bgp,debug,state RemoteAddress=10.100.0.1
     

    Вложения:

    • test2.gif
      test2.gif
      Размер файла:
      115,3 КБ
      Просмотров:
      4
  5. Илья Князев

    Илья Князев Администратор Команда форума

    Так а чего добиться-то хотите?
     
  6. unixlamaster

    unixlamaster Новый участник

    Пытаюсь построить связку OSPF+BGP+(MPLS позже) в отдельном VRF

    Меняю
    << /routing bgp instance
    << set default router-id=10.100.0.1 routing-table=core_vrf

    на
    >> /routing bgp instance
    >> set default redistribute-connected=yes redistribute-static=yes router-id=10.100.0.1
    ...
    >> /routing bgp instance vrf
    >> add redistribute-connected=yes redistribute-static=yes routing-mark=core_vrf

    Тогда в логах:
    05:25:55 route,bgp,debug Connecting
    05:25:55 route,bgp,debug RemoteAddress=10.100.0.2
    05:25:55 route,bgp,info Failed to open TCP connection: Network is unreachable
    05:25:55 route,bgp,info RemoteAddress=10.100.0.2
    05:27:00 route,bgp,debug Update source
    05:27:00 route,bgp,debug Address=10.100.0.1
    05:27:00 route,bgp,debug Connecting
    05:27:00 route,bgp,debug RemoteAddress=10.100.0.2
    05:27:00 route,bgp,info Failed to open TCP connection: Network is unreachable
    05:27:00 route,bgp,info RemoteAddress=10.100.0.2
    05:27:56 route,bgp,debug Update source
    05:27:56 route,bgp,debug Address=10.100.0.1
    05:27:56 route,bgp,debug Connecting
    05:27:56 route,bgp,debug RemoteAddress=10.100.0.2
    05:27:56 route,bgp,info Failed to open TCP connection: Network is unreachable
    05:27:56 route,bgp,info RemoteAddress=10.100.0.2
     
  7. unixlamaster

    unixlamaster Новый участник

    Скорее всего у меня не правильный подход...
    По http://wiki.mikrotik.com/wiki/VRF_Route_Leaking, надо VRF передовать по BGP, а не как я пытаться отделить BGP в отдельный VRF...
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

    Да. Так и есть.