Проблема с ВПН

Тема в разделе "Вопросы начинающих", создана пользователем VAsya, 8 окт 2016.

  1. VAsya

    VAsya Новый участник

    Настроен впн (l2tp\ipsec) между 2-мя микротиками.
    Все работает до перезагрузки.
    При перезагрузки микротик не успевает обновить время с NTP сервера,
    в связи с чем l2tp работает без ipsec.
    Для поднятия шифрования требуется разорвать соединение. Как это решается? Ручками нереально.

    скрипт при старте не стартует. Планировщик не срабатывает. В нем (микротике) все так? Без пинка ничего не работает :(

    /system scheduler
    add name=vpn on-event="/system script run vpnRestart\r\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive \
    start-time=startup
    /system script
    add name=vpnRestart owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/interface disable head\r\
    \ndelay 70\r\
    \n/interface enable head\r\
    \n"

    версия прошивки последняя, с предыдущей та же история.
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Конфиг покажете?
     
  3. VAsya

    VAsya Новый участник

    полный нет смысла, самое главное...

    сервер 3011

    /interface ethernet
    set [ find default-name=ether2 ] name=lan
    set [ find default-name=ether1 ] name=wan
    /interface wireless security-profiles
    set [ find default=yes ] supplicant-identity=MikroTik
    /ip ipsec proposal
    set [ find default=yes ] enc-algorithms=aes-128-cbc
    /ppp profile
    add change-tcp-mss=yes local-address=192.168.255.1 name=profile_l2tp use-upnp=yes use-encryption=yes
    /routing ospf area
    add area-id=192.168.20.0 name=area20
    /interface l2tp-server server
    set authentication=mschap2 default-profile=profile_l2tp enabled=yes ipsec-secret=IpSecPassword use-ipsec=yes
    /ip address
    add address=192.168.20.1/24 interface=lan network=192.168.20.0
    add address=10.1.1.1/24 interface=wan network=10.1.1.0
    /ppp secret
    add name=usr22 password=usr22 profile=profile_l2tp remote-address=192.168.255.22 service=l2tp
    /routing ospf network
    add area=backbone network=192.168.255.0/24
    add area=area20 network=192.168.20.0/24

    клиент rb951ui-2hnd

    /interface ethernet
    set [ find default-name=ether2 ] name=lan
    set [ find default-name=ether1 ] name=wan
    /interface l2tp-client
    add allow=mschap2 connect-to=10.1.1.1 disabled=no ipsec-secret=IpSecPassword mrru=1600 name=head password=usr22 use-ipsec=yes user=usr22
    /interface wireless security-profiles
    set [ find default=yes ] supplicant-identity=MikroTik
    /ip ipsec proposal
    set [ find default=yes ] enc-algorithms=aes-128-cbc
    /routing ospf area
    add area-id=192.168.22.0 name=area22
    /ip address
    add address=10.1.1.22/24 interface=wan network=10.1.1.0
    add address=192.168.22.1/24 interface=lan network=192.168.22.0
    /routing ospf network
    add area=area22 network=192.168.22.0/24
    add area=backbone network=192.168.255.0/24


    даже с такими настойками симптомы те-же.
    Еще проблема, при разрыве соединения (reboot) сервер еще держит соединение, ipsec так-же не соединяется, в лог пишет что незакрыто предыдущее соединение.

    Получается при перезагрузки\включении клиента соединение с vpn идет без шифрования. требуется ручками закрыть соединение. После чего все работает до следующего выключения\перезагрузки.

    С планировщик даже если создать пустой (без скрипта) сработает только 1 раз и все. Перезагружать\выключать можно сколько угодно, работать больше не будет.
    /system scheduler
    add name=schedule1 policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup
     
  4. VAsya

    VAsya Новый участник

    При покупки, настроил. Были проблемы описанные выше. Обновил прошивку на сервере и клиенте, проблемы те-же. (
     
  5. VAsya

    VAsya Новый участник

    проблема решена с помощью "костыля". Заработал скрипт. Нужно в начале скрипта делать паузу 5 сек. и он (скрипт) будет работать.

    скрипт при запуске\перезагрузки

    :delay 5
    :log info "vpn restart"
    /interface disable head
    :delay 70
    /interface enable head
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

    Свойство only-one в профиле ассоциированном с юзером со стороны сервера. Поставьте в Yes.
     
  7. Kowalsky

    Kowalsky Новый участник

    Добрый день
    Столкнулся с такой же проблемой после перезагрузки либо выключение включение микротика vpn работает без шифрования.
    Свойство only-one не решило проблему. Получается только скриптом можно решить проблему.
     
  8. Mook_34

    Mook_34 Участник

    Добрый день.
    У меня схожая проблема.
    При перезагрузки не подключается VPN L2Tp с сервером а когда от сервера к клиенту подключение сделать то сразу подключится.
    Пока не решил траблю.
     
  9. Илья Князев

    Илья Князев Администратор Команда форума

    В 6.38 много исправлений ipsec+l2tp. Попробуйте
     
  10. Mook_34

    Mook_34 Участник

    Спасибо . НО нечего не изменилось.Обновил и все то же.
     
  11. Mook_34

    Mook_34 Участник

    Доброй день.
    Прошло время...
    Поменял внешний IP адрес .Клиент подхватил и подключился без проблем.
    Буду смотреть дальше .