3 Wan 3 Lan

Тема в разделе "Маршрутизация", создана пользователем Syps, 10 июл 2016.

  1. Syps

    Syps Участник

    Mikrotik 2011

    Есть задача:
    ether1 - wan 1(Static)
    ether2- wan 2(DHCP)
    ether3- wan 3(DHCP)
    ether10- lan 1-3(192.168.77.1;192.168.66.1;192.168.55.1)

    Небоходима схема по которой:
    192.168.77.1 -> ether1
    192.168.66.1-> ether2
    192.168.55.1-> ether3

    Настройку произвожу по принципу:https://habrahabr.ru/post/227913/

    Но тут упираюсь в такой момент:
    Когда все маршруты IP->Route созданы с MarkRoute, в Mangle добавлены prerouting с no-mark и output,
    Шлюзы провайдеров с каждого интерфейса я вижу - Ping(ок), но интернета на локальной подсети нет.

    Проблема с тем, что в Route отсутствует маршрут с дистанцией "0", т.к. все маршруты, созданные по дефалту, пришлось удалить, что бы пометить MarkRoute. А маршруты созданные руками нельзя с нулевой дистанцией создавать.
     
  2. Syps

    Syps Участник

    Дистанцию Для
    ether1 - 2
    ether2- 3
    ether3- 4
     
  3. Илья Князев

    Илья Князев Администратор Команда форума

    Посмотрите мою презентацию на Московском MUM в сентябре 2015г. Там же видео есть.
    Реализация multiwan на RouterOS называется. http://mum.mikrotik.com/2015/RU/agenda
     
  4. Syps

    Syps Участник

    Спасибо. Посмотрел. Настроил всё как в мануале, но инет на локальном интерфейсе исчезает, как только начинаю маркировать Роуты.
     
  5. Илья Князев

    Илья Князев Администратор Команда форума

    Обратно их размаркировывать не забывайте?
     
  6. Syps

    Syps Участник

  7. Syps

    Syps Участник

    нет
    но как раз то правило Output молчит
     
  8. Syps

    Syps Участник

  9. Илья Князев

    Илья Князев Администратор Команда форума

    /ip firewall mangle export покажите.
     
  10. Syps

    Syps Участник

    Молчало
     
  11. Syps

    Syps Участник

    В экспорте только версию выводит
    jul/12/2016 01:24:16 by RouterOS 6.33.3
    # software id = 97UJ-FXXE
     
  12. Syps

    Syps Участник

    /ip firewall mangle export покажите. - я так понимаю это выводит список правил..
    Но у меня только /ip firewall mangle export выводит ul/12/2016 01:24:16 by RouterOS 6.33.3
    # software id = 97UJ-FXXE
     
  13. Syps

    Syps Участник

    может я что то не так делаю
     
  14. Илья Князев

    Илья Князев Администратор Команда форума

    Что-то не так. За этим должна конфигурация идти.
     
  15. Syps

    Syps Участник

    в фаил тоже експортирует только три строки
     
  16. Syps

    Syps Участник

    add action=mark-routing chain=prerouting in-interface=\
    ether1akado new-routing-mark=akado protocol=tcp
    add action=mark-routing chain=prerouting in-interface=\
    ether2Onlime827 new-routing-mark=Onlime protocol=tcp
    add action=mark-connection chain=prerouting in-interface=\
    ether1akado new-connection-mark=conAkado
    add action=mark-connection chain=prerouting in-interface=\
    ether2Onlime827 new-connection-mark=conOnlime
    add action=mark-routing chain=prerouting connection-mark=\
    conAkado new-routing-mark=routeAkado
    add action=mark-routing chain=prerouting connection-mark=\
    conOnlime new-routing-mark=routeOnlime
    add action=mark-routing chain=output connection-mark=conAkado \
    new-routing-mark=routeAkado
    add action=mark-routing chain=output connection-mark=conOnlime \
    new-routing-mark=routeOnlime
     
  17. Илья Князев

    Илья Князев Администратор Команда форума

    А зачем вы на входе маркируете?
    Когда на маршрутизацию приходит пакет с route-mark то логика следующая.
    Если в таблице маршрутизации есть маршрут с маркировкой - то будет использован маршрут с маркировкой.
    Если нет такого маршрута - будет использован маршрут без маркировки.
    У вас на WAN приходит пакет.
    Вы его маркируете.
    При выборе маршрута у вас есть маркированный 0.0.0.0/0
    Пакет улетает назад в Интернет.
     
    Последнее редактирование: 11 июл 2016
  18. Syps

    Syps Участник

    Его надо перенаправить в сеть
     
  19. Илья Князев

    Илья Князев Администратор Команда форума

    Еще раз.
    1. Маркируем соединения в input
    2 Используем эти маркировки при маркировке маршрутов в Output
    Это нужно чтобы если пакет пришел на роутер снаружи, он ушел назад через тот же интерфейс.
    Для клиентов
    Маркируем в prerouting маршруты НАРУЖУ.
    НЕ МАРКИРУЕМ ТО ЧТО ИДЕТ СНАРУЖИ НАЗАД!!!
     
  20. Syps

    Syps Участник

    Мне не нужна параллельная работа интерфейсов. Мне нужно, что бы все пакеты и всегда с ether10Lan1 - ether1wan1, ether10Lan2 - ether2wan2.
    Они никогда не должны пересекаться