CAPSMAN и сторонний DHCP

Тема в разделе "Беспроводные технологии", создана пользователем Corwin, 8 июн 2017.

  1. Corwin

    Corwin Новый участник

    Коллеги, доброго дня.

    Не так давно начал тестировать capsman и есть необходимость настроить получение ip ( для клиентов) с внешнего dhcp сервера. Реализуемо ли это? Если да, то как?
     
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Реализуемо.
    Надо добавить порт с DHCP в соответсвующий Bridge.
     
  3. Corwin

    Corwin Новый участник

    Спасибо за ответ. С утра разобрался в чём была проблема. Убрал vlan из datapaths и dhcp relay заработал. На данный момент vlan прописан в интерфейсах и прикреплен к ether1. Затем vlan собран в bridge на котором висит ip. Не знаю на сколько это правильно, но вроде работает (нет).

    Ip клиентское устройство теперь получает, только выйти никуда не может. Возможно я настроил криво.
    Не совсем очевидно как должны быть настроены default маршруты для разных vlan. На данный момент имеется два vlan: управления и для SSID.

    Код:
    /caps-man channel
    add band=2ghz-b/g/n comment="2.4 Ghz" control-channel-width=20mhz extension-channel=disabled frequency=2412 name="Channel 1" tx-power=18
    add band=2ghz-b/g/n control-channel-width=20mhz extension-channel=disabled frequency=2437 name="Channel 6" tx-power=18
    add band=2ghz-b/g/n control-channel-width=20mhz extension-channel=disabled frequency=2462 name="Channel 11" tx-power=18
    add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=disabled frequency=5180 name="Channel 36" tx-power=18
    add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=disabled frequency=5230 name="Channel 46" tx-power=18
    add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=disabled frequency=5320 name="Channel 64" tx-power=18
    /interface bridge
    add name="Mikrotik_Test1 (Bridge)" protocol-mode=none
    /interface vlan
    add interface=ether1 name=Management vlan-id=717
    add interface=ether1 name=Mikrotik_Test1 vlan-id=718
    /caps-man datapath
    add arp=enabled bridge="Mikrotik_Test1 (Bridge)" mtu=1500 name=Utkonos_mikrotik_test
    /caps-man security
    add authentication-types=wpa2-psk encryption=aes-ccm,tkip name=Utkonos_mikrotik_test passphrase=fuckmikrotik
    /caps-man configuration
    add channel="Channel 1" country=russia datapath=Utkonos_mikrotik_test distance=indoors mode=ap multicast-helper=default name="Utkonos_mikrotik_test 2.4 Ghz" rx-chains=0,1,2 security=Utkonos_mikrotik_test ssid=Utkonos_mikrotik_test tx-chains=0,1,2
    add channel="Channel 36" country=russia datapath=Utkonos_mikrotik_test distance=indoors mode=ap name="Utkonos_mikrotik_test 5ghz" rx-chains=0,1,2 security=Utkonos_mikrotik_test ssid=Utkonos_mikrotik_test tx-chains=0,1,2
    /ip pool
    add name=dhcp_pool0 ranges=10.50.218.1-10.50.218.250,10.50.218.252-10.50.218.254
    /caps-man manager
    set enabled=yes
    /caps-man provisioning
    add action=create-dynamic-enabled hw-supported-modes=gn master-configuration="Utkonos_mikrotik_test 2.4 Ghz"
    add action=create-dynamic-enabled hw-supported-modes=an master-configuration="Utkonos_mikrotik_test 5ghz"
    /interface bridge port
    add bridge="Mikrotik_Test1 (Bridge)" interface=Mikrotik_Test1
    /interface l2tp-server server
    set caller-id-type=ip-address
    /ip address
    add address=10.50.217.1/24 interface=Management network=10.50.217.0
    add address=10.50.218.251/24 interface="Mikrotik_Test1 (Bridge)" network=10.50.218.0
    /ip dhcp-relay
    add dhcp-server=10.50.1.33 disabled=no interface="Mikrotik_Test1 (Bridge)" local-address=10.50.218.251 name=relay1
    /ip dhcp-server network
    add address=10.50.218.0/24 dns-server=10.50.1.1 gateway=10.50.218.251
    /ip route
    add distance=1 gateway=10.50.218.254
    add distance=1 gateway=Management
    
    P.S. Сам Router OS c capsman является виртуалкой на гипервизоре.
     
    Последнее редактирование: 9 июн 2017
  4. Илья Князев

    Илья Князев Администратор Команда форума

    Обычно так и делается.
    А вот этого вопроса не понял.
     
  5. Corwin

    Corwin Новый участник

    Суть проблемы заключается в том, что клиент получает ip, может пинговать адрес бриджа и больше никуда выйти не может. То есть, например, с L3 коммутатора ( который является gw для CHR) я не могу достучатся до клиента в wifi сети.
    Как я уже говорил, на текущий момент на к CHR приходит два vlan: один управления, один для SSID. Соответственно есть две отдельные подсети в каждом в vlan'e и для обоих подсетей прописаны дефолтные маршруты.
    На сколько я могу судить, router OS использует только один из них.
    Я предположил, что возможно маршрутизация должна как-то хитрее настраиваться, хотя в случае с контроллерами других производителей все примерно так и выглядит : 1 vlan - 1 default gateway.
     
  6. Илья Князев

    Илья Князев Администратор Команда форума

    Если клиент может только бридж пинговать, то дальше или Нат или роутинг или файрвол.