hotspot and queue tree

Тема в разделе "Общий форум", создана пользователем Vasko, 9 янв 2017.

  1. Vasko

    Vasko Новый участник

    Добрый день! задался вопросом организации hotspot с разделением трафика. и все вроде бы работало, но потом в одну очередь перестали падать пакеты, хотя в мангле правило для ip есть, трафик через него идет, маркировка правильная, но в очереди счетчик по нулям.
    Fsattrack отключен(по крайней мере в ip firwall rules ничего о fasttrack нет). сделано так: upload_2017-1-9_13-18-45.png
    ранее в очередь QueueTree_out_guest трафик падал, потом просто так перестал. видно что ip 192.168.33.167 маркируется и присутствует.
    еще дополнительный вопрос: все queue type общие для исх и вх трафика hotspot-default. корректно ли это?
     

    Вложения:

    Последнее редактирование: 9 янв 2017
  2. Vasko

    Vasko Новый участник

    в добавление конфиг:
    /queue type
    set 4 kind=pcq pcq-classifier=src-address,dst-address,src-port,dst-port \
    pcq-rate=13M

    /queue tree
    add limit-at=10M max-limit=10M name=queueTree_in_global_upload packet-mark=\
    in_guest,in_conf10,in_conf20,no-mark parent=global queue=hotspot-default
    add limit-at=10M max-limit=10M name=queueTree_out_global_download \
    packet-mark="out_guest,out_conf10,out_conf 20,no-mark" parent=global \
    queue=hotspot-default
    add limit-at=8M max-limit=10M name=queueTree_in_guest packet-mark=in_guest \
    parent=queueTree_in_global_upload queue=hotspot-default
    add limit-at=2M max-limit=2M name=queueTree_in_conf10 packet-mark=in_conf10 \
    parent=queueTree_in_global_upload priority=7 queue=hotspot-default
    add limit-at=2M max-limit=2M name=queueTree_in_conf20 packet-mark=in_conf20 \
    parent=queueTree_in_global_upload priority=7 queue=hotspot-default
    add limit-at=8M max-limit=10M name=queueTree_out_guest packet-mark=out_guest \
    parent=queueTree_out_global_download priority=7 queue=hotspot-default
    add limit-at=2M max-limit=4M name=queueTree_out_conf10 packet-mark=out_conf10 \
    parent=queueTree_out_global_download priority=7 queue=hotspot-default
    add limit-at=2M max-limit=2M name=queueTree_out_conf20 packet-mark=\
    "out_conf 20" parent=queueTree_out_global_download priority=7 queue=\
    hotspot-default



    /ip firewall mangle

    add action=jump chain=forward jump-target=hotspot src-address-list=\
    hotspotAddList
    add action=jump chain=forward dst-address-list=hotspotAddList jump-target=\
    hotspot
     
  3. Vasko

    Vasko Новый участник

    ну продолжу свой монолог:
    переключил parent основания дерева download с global на bridge и все работает пока. в чем шаманство не пойму
    upload_2017-1-10_11-37-41.png
     

    Вложения: