Проброс портов для IP-камеры

Тема в разделе "Вопросы начинающих", создана пользователем Заяц, 13 окт 2015.

  1. Заяц

    Заяц Новый участник

    Доброго дня.
    Возникла необходимость у начальства полюбоваться работой сотрудников.
    Повесили камеру, настроили, но не суть...
    А суть вот в чем: Сижу и настраиваю проброс для камеры через WinBox v6.6
    Зашел по инструкции в ip/firewall/NAT
    И создал 4 правила: dsnat tcp 3333 ether1 /netmap 192.168.*.* 80, тоже самое повторил для udp на ether1, и повторил для ether2.
    Пытаюсь пробиться из внешки по staticIP данного провайдером по порту 3333.... Ан нет, web интерфейса камеры не видно, и вообще ничего. Страница не найдена.
    Подскажите что не так сделано? Может для просмотра из вне не dsnat a srcnat нужен. или не дописал чего?
     
  2. vasilevkirill

    vasilevkirill Участник

    ну для начало почему netmap? использейте dst-nat
    Код:
    /ip firewall nat add in-interface=ether1 protocol=tcp dst-port=3333 action=
    dst-nat to-addresses=192.168.0.80
     
  3. Заяц

    Заяц Новый участник

    Прочитал на форуме что dsnat & netmap идентичны, сейчас проверим Вашу подсказку
     
  4. Заяц

    Заяц Новый участник

    Не вышло. Вопрос а интерфейс должен быть LAN или WAN?
     
  5. vasilevkirill

    vasilevkirill Участник

    интерфейс провайдера должен быть в in-interface
    покажите все правила NAT
     
  6. Заяц

    Заяц Новый участник

    https://cloud.mail.ru/public/4PLR/R5pf5dYQE
     
  7. vasilevkirill

    vasilevkirill Участник

    покажите номрально /ip firewall export
     
  8. Илья Князев

    Илья Князев Администратор Команда форума

  9. Заяц

    Заяц Новый участник

    [admin@Barklaya] /ip firewall nat> /ip firewall export
    # sep/04/2002 04:11:11 by RouterOS 6.6
    # software id = IW88-STST
    #
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
    add action=drop chain=forward dst-address=192.168.7.1 hotspot=from-client port=22 protocol=tcp
    add action=drop chain=input dst-address=192.168.7.227 hotspot=from-client port=22 protocol=tcp
    add action=drop chain=input dst-address=10.5.50.1 hotspot=from-client port=22 protocol=tcp
    add chain=forward dst-address=192.168.7.1 src-address=10.5.50.0/24
    add action=reject chain=forward comment="Reject from Hotspot to internal" dst-address=10.100.0.0/16 src-address=\
    10.5.50.0/24
    add action=reject chain=forward dst-address=192.168.0.0/16 src-address=10.5.50.0/24
    add action=reject chain=input dst-address=84.47.135.49 src-address=10.5.50.0/24
    add chain=input comment="default configuration" protocol=icmp
    add chain=input comment="default configuration" connection-state=established
    add chain=input comment="default configuration" connection-state=related
    add action=drop chain=input comment="default configuration" in-interface=ether1
    add action=drop chain=input in-interface=ether2
    add action=drop chain=input comment="default configuration" in-interface=sfp1-gateway
    add chain=forward comment="default configuration" connection-state=established
    add chain=forward comment="default configuration" connection-state=related
    add action=drop chain=forward comment="default configuration" connection-state=invalid
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes to-addresses=0.0.0.0
    add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1
    add action=masquerade chain=srcnat out-interface=ether2
    add action=masquerade chain=srcnat comment="default configuration" disabled=yes out-interface=sfp1-gateway
    add action=masquerade chain=srcnat comment="masquerade hotspot network" src-address=10.5.50.0/24 to-addresses=0.0.0.0
    add action=dst-nat chain=dstnat dst-port=3333 in-interface=ether1 protocol=tcp to-addresses=192.168.7.253 to-ports=80
    add action=dst-nat chain=dstnat dst-port=3333 in-interface=ether1 protocol=udp to-addresses=192.168.7.253 to-ports=80
    add action=dst-nat chain=dstnat dst-port=3333 in-interface=ether2 protocol=tcp to-addresses=192.168.7.253 to-ports=80
    add action=dst-nat chain=dstnat dst-port=3333 in-interface=ether2 protocol=udp to-addresses=192.168.7.253 to-ports=80
    [admin@Barklaya] /ip firewall nat>
    [admin@Barklaya] /ip firewall nat>
     
  10. Заяц

    Заяц Новый участник

    Интересует решение проблемы.
    Чай с плюшками конечно хорошо, но не мартини... не мартини! )))
     
  11. vasilevkirill

    vasilevkirill Участник

    Добрый день,
    хорошей практикой, является правила src,masquerade NAT ставить в самый низ.

    Скажите когда вы пытаетесь зайти через ether1 по tcp/3333 счётчик пакетов на правиле увеличивается?
     
  12. Заяц

    Заяц Новый участник

    Извиняюсь за вопрос ламера: как вычислить?
    По поводу хорошей практики, тот кто настраивал уже не работает. А мне как экономисту -менеджеру до полного понимания еще очень далеко