Устройство Mikrotik SXT LTE не работает «из коробки»

Тема в разделе "Общий форум", создана пользователем vinsenty, 7 ноя 2016.

  1. vinsenty

    vinsenty Новый участник

    Устройство Mikrotik RouterBOARD SXT LTE (RBSXTLTE3-7).

    Предустановленная прошивка 6.34.4. При настройке использована стандартная конфигурация и настройка через окно «Quick Set». Индикация сигнала LTE (Megafon Москва) появляется через 5-10 мин после первой настройки (выбор 7 частотного диапазона и APN мегафона), а после последующих перезагрузок через 1-3 мин. Интерфейс lte1 получает статус «running». Т.е. все соответствует описанию настройки и работы устройства в интернете. Но интернет соединение не появляется ни в ОС (браузере), ни в терминале Winbox.

    Перепробованы пошивки 6.34.2, 6.35.4 и последняя 6.37.1 из «Current release tree», и 6.32.4 и 6.36.4 из «Bugfix release tree». Результат такой же.

    Интернет появляется, либо при выборе режима «Use Peer DNS» (есть в последних версиях прошивок) во вкладке Winbox «Interface-lte1, либо добавлением дополнительного DNS сервера в список DNS во вкладке IP-DNS.
    То есть, во всех стандартных конфигурациях перепробованных прошивок служба DNS не работает должным образом без дополнительных настроек.

    Устройство не работает так, как должно работать, и так, как работает у других пользователей. В чем может быть дело?

    P.S. Все перепробованные прошивки выбирались по информации в интернете о том, что устройство с ними у других пользователей работало без каких-либо проблем. После смены прошивок конфигурация сбрасывалась в заводскую установку разными способами (и программно, и кнопкой Reset). Firmware обновлялось при необходимости через вкладку System-Routerboard. Прошивки брались и из обновлений в WinBox, когда это было возможно, так и с сайта http://www.mikrotik.com/download

    Файл экспорта конфигурации - в приложении
    - стандартная конфигурация для прошивки 6.37.1, пакет LTE оставлен 6.36.4;
    - LTE - настоен и работает;
    - в службу DNS изменений (по отношению к стандартной настройки) не вносилось
    и, соответственно, интернета нет

    Конфиг:
    Код:
    # nov/08/2016 03:57:11 by RouterOS 6.37.1
    # software id = XAKH-SEC7
    #
    /interface lte
    set [ find ] add-default-route=yes apn=internet default-route-distance=1 \
        ip-type=ipv4 ipv6-interface=none mac-address=00:0A:3B:F0:00:00 name=lte1 \
        network-mode=lte
    /ip neighbor discovery
    set lte1 discover=no
    /ip pool
    add name=dhcp ranges=192.168.88.10-192.168.88.254
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=ether1 name=defconf
    /ip address
    add address=192.168.88.1/24 comment=defconf interface=ether1 network=\
        192.168.88.0
    add address=172.21.251.182/24 interface=lte1 network=172.21.251.0
    /ip dhcp-server network
    add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
    /ip dns
    set allow-remote-requests=yes
    /ip dns static
    add address=192.168.88.1 name=router
    /ip firewall filter
    add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
    add action=accept chain=input comment="defconf: accept established,related" \
        connection-state=established,related
    add action=drop chain=input comment="defconf: drop all from WAN" \
        in-interface=lte1
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
        connection-state=established,related
    add action=accept chain=forward comment="defconf: accept established,related" \
        connection-state=established,related
    add action=drop chain=forward comment="defconf: drop invalid" \
        connection-state=invalid
    add action=drop chain=forward comment=\
        "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
        connection-state=new in-interface=lte1
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" \
        out-interface=lte1
    /system clock
    set time-zone-name=Asia/Krasnoyarsk
    /system routerboard settings
    set init-delay=0s protected-routerboot=disabled
    /tool mac-server
    set [ find default=yes ] disabled=yes
    add interface=ether1
    /tool mac-server mac-winbox
    set [ find default=yes ] disabled=yes
    add interface=ether1
    
     
    Последнее редактирование: 8 ноя 2016
  2. Илья Князев

    Илья Князев Администратор Команда форума

    Обновиться до 6.37.1
    поставить пакет lte из расширенных пакетов.
     
  3. vinsenty

    vinsenty Новый участник

    Я написал, что "оставлен" пакет LTE 6.36.4. Он как раз и появился при установке прошивки 6.36.4 и LTE 6.36.4 из состава расширенных пакетов.
    Потом ставилась прошивка 6.37.1 (она и сейчас установлена), а к ней LTE 6.37.1 - то, что Вы советуете.
    Даунгрейт LTE обратно на версию 6.36.4 был сделан потому как казалось, что подхват мобильного сигнала на последней версии происходит дольше (данная мысль не подтвердилась, а версия LTE 6.36.4 - осталась).
    Когда прошивка спускалась до 6.34.2, то и пакет LTE прошивался под нее...
    Но интернета, как не было, так и нет, без добавочных настроек DNS.
    Т.е. устройство работает не так, как ожидается. Вопрос: почему?

    P.S. Казалось бы, зачем выяснять, если можно заставить устройство работать, добавив, например, 8.8.8.8 в список DNS и/или явно указав передачу клиентам DHCP серверов провайдера («Use Peer DNS»)
    Но если что-то не так работает в одном месте, то какова вероятность, что что-то не так где-то еще, чего я пока не заметил? Именно это и смущает! Нужно понять причину.
    Для меня это всего лишь второе устройство Mikrotik. И опыта явно мало.
     
    Последнее редактирование: 8 ноя 2016
  4. Илья Князев

    Илья Князев Администратор Команда форума

    Ага. Вы клиента отдаете DNS как адрес роутера. Правильно понял?
     
  5. merdzd

    merdzd Новый участник

    +1.
    Работает только с гугловским ДНС в настройках.
    Мегафон:
    APN internet
    APN public.msk

    А
    APN fixedip.msk
    Даже с гугл\яндекс ДНС не работает.
    Хотя выдаёт IP нужный и свои ДНС прописывает.

    Use Peer DNS не влияет особо.
     
  6. merdzd

    merdzd Новый участник

    Update
    Проблему с Статитческим IP мегафон решил. теперь он присваеввается на номер даже без прописывания APN fixedip.msk
    А вот ДНС ip они мне пытаются прописать из 10.х.х.х диапазона.
     
  7. Илья Князев

    Илья Князев Администратор Команда форума

    Так не принимайте его от Мегафона.
     
  8. merdzd

    merdzd Новый участник

    Можно и так. Но как то не кашерно, и учитывая что эта симка работает на обычных модемах без проблем (не прописывания паблик DNS).
    То проблемма именно в Mikrotik LTE.
     
  9. merdzd

    merdzd Новый участник

    После первых 2х обращений которые мегафон закрыли автоматом. На третем обращении исправили.
     
  10. Илья Князев

    Илья Князев Администратор Команда форума